Project

General

Profile

Feature #31479

System -> Email -> SMTP Authentication

Added by Michael Reynolds over 2 years ago. Updated over 2 years ago.

Status:
Done
Priority:
Important
Assignee:
Dennis Mullen
Category:
GUI (new)
Estimated time:
Severity:
Low
Reason for Closing:
Not to be fixed
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
Tags:

Description

The Username and Password/Confirm Password fields should be hidden unless the SMTP Authentication checkbox is actually checked.

OLD-EMAIL.png (40.9 KB) OLD-EMAIL.png Vaibhav Chauhan, 04/07/2018 06:23 PM
NEW-EMAIL.png (34.2 KB) NEW-EMAIL.png Vaibhav Chauhan, 04/07/2018 06:23 PM
16248
16251

Associated revisions

Revision 43a423bd (diff)
Added by Dennis K. over 2 years ago

Hide email fields when SMTP not selected Ticket: #31479

Revision b1328b2e (diff)
Added by Dennis K. over 2 years ago

Added validators Ticket: #31479

Revision fcb552b6 (diff)
Added by Dennis K. over 2 years ago

Hide email fields when SMTP not selected Ticket: #31479 (cherry picked from commit 43a423bd5cc77dede441cc15b1a7ceb6c5bc3785)

Revision 5be6126c (diff)
Added by Dennis K. over 2 years ago

Added validators Ticket: #31479 (cherry picked from commit b1328b2e8b2018abecea05b5bbfcfcda19a5f546)

History

#1 Updated by Erin Clark over 2 years ago

  • Assignee changed from Erin Clark to Vaibhav Chauhan

#2 Updated by Vaibhav Chauhan over 2 years ago

16248
16251

OLD UI behaves the same way, so this is something more like a feature request than a bug.

#3 Updated by Dru Lavigne over 2 years ago

  • Category changed from GUI (new) to Middleware
  • Status changed from Closed to Not Started
  • Assignee changed from Vaibhav Chauhan to William Grzybowski
  • Target version changed from N/A to 11.2-RC2
  • Reason for Closing deleted (Behaves as Intended)

#4 Updated by William Grzybowski over 2 years ago

  • Tracker changed from Bug to Feature
  • Category changed from Middleware to GUI (new)
  • Assignee changed from William Grzybowski to Vaibhav Chauhan
  • Seen in deleted (Master - FreeNAS Nightlies)
  • ChangeLog Required deleted (No)

#5 Updated by William Grzybowski over 2 years ago

This is UI thing, not related to middleware at all.

This needs to be discussed with UI team as a general concept: should fields be hidden or disabled in cases like these?

#6 Updated by Vaibhav Chauhan over 2 years ago

  • Assignee changed from Vaibhav Chauhan to Erin Clark

please let me know if this needs any work or not ?

#7 Updated by Erin Clark over 2 years ago

  • Assignee changed from Erin Clark to Vaibhav Chauhan

go ahead and hide the fields if the box isn't checked

#8 Updated by Vaibhav Chauhan over 2 years ago

  • Status changed from Not Started to Done

I had word with Erin, and it looks like Erin is comfortable with current workflow. so closing it out.

#9 Updated by Dru Lavigne over 2 years ago

  • Status changed from Done to Closed
  • Target version changed from 11.2-RC2 to N/A
  • Reason for Closing set to Not to be fixed

#10 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Status changed from Closed to Not Started
  • Assignee changed from Vaibhav Chauhan to Dennis Mullen
  • Target version changed from N/A to 11.3

#11 Updated by Dennis Mullen over 2 years ago

  • Status changed from Not Started to In Progress
  • Priority changed from No priority to Important
  • Severity set to Low

#12 Updated by Dennis Mullen over 2 years ago

  • Status changed from In Progress to Done

#13 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.3 to Master - FreeNAS Nightlies
  • Needs Merging changed from Yes to No

Also available in: Atom PDF