Project

General

Profile

Bug #3150

mountd and umlauts

Added by hellweiss - about 7 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Nice to have
Assignee:
Erin Clark
Category:
OS
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hi,

mountd does not work with umlauts,seen in 9.2-ALPHA

console.log
--- snip ---
kernel: Sep 13 13:22:56 tknas winbindd5293: Kinit failed: Preauthentication failed
kernel: Sep 13 13:22:58 tknas mountd3833: unknown group: dom|nen-admins
--- snip ---

History

#1 Updated by Jordan Hubbard almost 7 years ago

  • Assignee set to William Grzybowski
  • Target version set to 9.2.0-RELEASE

Hey William, is this more of the UTF-8 issues in FreeNAS? How hard is it to make the UI and underlying system more Unicode friendly? If it's a major effort, we should push it out to NMR. If it's just setting an environment variable or something, might be worthwhile!

#2 Updated by William Grzybowski almost 7 years ago

  • Status changed from Unscreened to Screened

This doesn't sound like an issue with UTF-8, but an escape issue in the shell script for AD?

We have already been making it unicode friendly as the issues arises.

#3 Updated by William Grzybowski almost 7 years ago

  • Assignee changed from William Grzybowski to John Hixson

I tested a local group with umlauts and it worked. The real issue here seems to be indeed that AD failed and then mountd failed because the group did not exist.

Handing over to John (let me know if there is something I can do on my side).

Thanks

#4 Updated by Josh Paetzel almost 7 years ago

  • Assignee changed from John Hixson to hellweiss -
  • Target version changed from 9.2.0-RELEASE to 49
  • Seen in changed from 9.2.0-RELEASE to

The root cause of this is AD is failing to bind. Can you attach the save debug? (It's a button in system -> settings)

#5 Updated by hellweiss - almost 7 years ago

  • File debug-tknas-20131128081553.tgz added

Here you are

best regards

hellweiss

#6 Updated by Jordan Hubbard over 6 years ago

  • Category changed from 39 to 36
  • Assignee changed from hellweiss - to John Hixson

OK, this is one for Directory Services and John. Over to you, John!

#7 Updated by Jordan Hubbard over 4 years ago

  • Assignee changed from John Hixson to Wojciech Kloska

#8 Updated by Jordan Hubbard over 4 years ago

  • Assignee changed from Wojciech Kloska to Erin Clark

#9 Updated by Jordan Hubbard over 4 years ago

  • Status changed from Screened to Closed
  • Seen in changed from to 8.3.1-RELEASE

BRB: Timing out

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from 49 to N/A

#11 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-tknas-20131128081553.tgz)

Also available in: Atom PDF