Project

General

Profile

Bug #31686

There is no option to lock a newly created encrypted volume in the new GUI

Added by Bonnie Follweiler over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Important
Assignee:
Peter Southwell
Category:
GUI (new)
Target version:
Severity:
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I upgraded to FreeNAS-11-MASTER-201804100626
There is no option to lock an encrypted volume in the GUI

Screen Shot 2018-04-10 at 12.46.48 PM.png (35.5 KB) Screen Shot 2018-04-10 at 12.46.48 PM.png Bonnie Follweiler, 04/10/2018 09:53 AM
Screen Shot 2018-04-10 at 12.53.15 PM.png (24.6 KB) Screen Shot 2018-04-10 at 12.53.15 PM.png Bonnie Follweiler, 04/10/2018 09:53 AM
Screen Shot 2018-04-10 at 1.03.47 PM.png (122 KB) Screen Shot 2018-04-10 at 1.03.47 PM.png Bonnie Follweiler, 04/10/2018 10:05 AM
Screen Shot 2018-04-10 at 1.04.12 PM.png (43 KB) Screen Shot 2018-04-10 at 1.04.12 PM.png Bonnie Follweiler, 04/10/2018 10:06 AM
Screen Shot 2018-04-10 at 1.04.32 PM.png (79.5 KB) Screen Shot 2018-04-10 at 1.04.32 PM.png Bonnie Follweiler, 04/10/2018 10:06 AM
Screen Shot 2018-04-10 at 1.10.00 PM.png (58.5 KB) Screen Shot 2018-04-10 at 1.10.00 PM.png Bonnie Follweiler, 04/10/2018 10:11 AM
Screen Shot 2018-04-10 at 1.10.11 PM.png (21.1 KB) Screen Shot 2018-04-10 at 1.10.11 PM.png Bonnie Follweiler, 04/10/2018 10:11 AM
screenshot.png (169 KB) screenshot.png Peter Southwell, 04/10/2018 10:08 PM
16335
16338
16341
16344
16347
16350
16353
16407

Related issues

Related to FreeNAS - Bug #30855: I can't find how to unlock volume with passphraseClosed2018-03-27
Is duplicate of FreeNAS - Bug #31683: There is no place to add a passphrase to an encrypted volumeDone2018-04-10

History

#1 Updated by Bonnie Follweiler over 2 years ago

16341
16344
16347

In the old GUI, after you created a passphrase you have the option to lock the drive. You can then unlock it with the passphrase (see Screenshots)

#2 Updated by Bonnie Follweiler over 2 years ago

16350
16353

If I create a Passphrase, in the Legacy GUI, and lock the volume, the lon in to the New GUI and try to unlock, it asks for the passphrase to unlock it.

#3 Updated by Bonnie Follweiler over 2 years ago

  • Subject changed from There is no option to lock an encrypted volume in the new GUI to There is no option to lock a newly created encrypted volume in the new GUI

#4 Updated by Erin Clark over 2 years ago

  • Assignee changed from Erin Clark to Peter Southwell
  • Priority changed from No priority to Important

#5 Updated by Peter Southwell over 2 years ago

16407

The secrete is... First you must create a Pass phrase for the volume..... Once you do that..

"Lock" appears.... When you execute lock.. and the volume is locked.. It changes to "UnLock"

Also.. This is not under the gears menu.. It's under the picture of the LOCK.. That's it's own menu.

1) Create Passphrase
2) Lock appears.
3) Lock.. (Unlock hidden)
4) UnLocak appears (Lock Hidden).

So bascially.. You must first create a passphrase.... Then you'll see the lock. We do this because Lock would fail if no passphrase. :)

#6 Updated by Dru Lavigne over 2 years ago

  • Related to Bug #30855: I can't find how to unlock volume with passphrase added

#7 Updated by Dru Lavigne over 2 years ago

  • Is duplicate of Bug #31683: There is no place to add a passphrase to an encrypted volume added

#8 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.2-BETA1 to N/A
  • Reason for Closing set to Duplicate Issue

Bonnie has confirmed that this is resolved by the duplicated ticket.

Also available in: Atom PDF