Project

General

Profile

Bug #31692

Redundant pathway to system general

Added by Aaron St. John over 2 years ago. Updated over 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Damian Szidiropulosz
Category:
GUI (new)
Severity:
Reason for Closing:
Behaves as Intended
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I have found that the Cog wheel ("Settings") in the top right has another option in the drop down called "Settings" with another cog wheel icon.
If a user was to click this drop down, it navigates to "System --> General."

Suggestions: Either rename the redundant "Settings" option in the drop down to something appropriate for "System --> General" or Just eliminate
the redundancy and remove the "Settings" option from the drop down of the "Settings" menu.

settings_redundancy.png (149 KB) settings_redundancy.png Aaron St. John, 04/10/2018 10:44 AM
16356

History

#1 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Erin Clark
  • Target version set to 11.2-BETA1

#2 Updated by Erin Clark over 2 years ago

I have seen this redundancy but I think it is better that users can reach it from either place, System > General is the traditional route to get here but it is also convenient to have it on the menu so one can change time zone/language/etc. from there. Or at least that is my opinion.

#3 Updated by Erin Clark over 2 years ago

  • Status changed from Unscreened to Closed
  • Reason for Closing set to Behaves as Intended

#4 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.2-BETA1 to N/A

#5 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Status changed from Closed to Not Started

Rework/Update the icon for the "top right" settings.

#6 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Erin Clark to Damian Szidiropulosz
  • Target version changed from N/A to 11.2-RC2

And remove "Settings" from the drop-down menu as it is redundant (available in left frame menu).

#7 Updated by Damian Szidiropulosz over 2 years ago

  • Status changed from Not Started to In Progress

#8 Updated by Damian Szidiropulosz over 2 years ago

  • Status changed from In Progress to Done

PR 660 fixes this.

#9 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.2-RC2 to Master - FreeNAS Nightlies
  • Needs Merging changed from Yes to No

Also available in: Atom PDF