Project

General

Profile

Bug #31707

The Cancel buttons aren't in a consistent place between the unlock an encrypted pool dialog box and the Enter the Passphrase dialog box

Added by Bonnie Follweiler over 2 years ago. Updated over 2 years ago.

Status:
Done
Priority:
Important
Assignee:
Dennis Mullen
Category:
GUI (new)
Severity:
Low
Reason for Closing:
Behaves as Intended
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I upgraded to FreeNAS-11-MASTER-201804100626
I was unlocking an encrypted pool and I noticed that the Cancel buttons aren't in a consistent place between the unlock an encrypted pool dialog box and the Enter the Passphrase dialog box (screenshots provided). I'm not sure which one is the "standard"

Associated revisions

Revision 835a194c (diff)
Added by Dennis Mullen over 2 years ago

Remove comment Ticket: #31707

Revision cff0fe9e (diff)
Added by Dennis Mullen over 2 years ago

Update dialog config interface Ticket: #31707

Revision 41875087 (diff)
Added by Dennis Mullen over 2 years ago

Remove unused form for unlocking pools Ticket: #31707

History

#1 Updated by Erin Clark over 2 years ago

  • Assignee changed from Erin Clark to Dennis Mullen
  • Priority changed from No priority to Important

#2 Updated by Dennis Mullen over 2 years ago

Even though the placement varies, I think this is proper use, assuming the 'decrypt pool' is a form and the 'unlock pool'is a dialog. From the [material design spec](https://material.io/guidelines/components/buttons.html#buttons-usage):

Standard dialogs - Button alignment on screen: right

Place the affirmative button on the right, the dismissive button on the left.

Forms -
Button alignment on screen: Left

Place the affirmative button on the left, the dismissive button on the right.

- Dennis

#3 Updated by Dennis Mullen over 2 years ago

  • Status changed from Unscreened to Screened

#4 Updated by Dennis Mullen over 2 years ago

  • Status changed from Screened to Closed

Even though the placement varies, it is consistent with the material design spec. The 'decrypt pool' is a form and the 'unlock pool'is a dialog. From the [material design spec](https://material.io/guidelines/components/buttons.html#buttons-usage):

Standard dialogs - Button alignment on screen: right
Place the affirmative button on the right, the dismissive button on the left.
Forms -
Button alignment on screen: Left
Place the affirmative button on the left, the dismissive button on the right.

#5 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.2-BETA1 to N/A
  • Reason for Closing set to Behaves as Intended

#6 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Status changed from Closed to Not Started
  • Target version changed from N/A to 11.3

Reopening and punting to 11.3

#7 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

Switch to consistent type. Forms use forms, dialog box to boxes.

#8 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Target version changed from 11.3 to Backlog

#9 Updated by Dennis Mullen over 2 years ago

  • Severity set to Low

#10 Updated by Dennis Mullen over 2 years ago

  • Status changed from Not Started to In Progress

#11 Updated by Dennis Mullen over 2 years ago

PR 848

#12 Updated by Dru Lavigne over 2 years ago

  • Status changed from In Progress to Done
  • Target version changed from Backlog to Master - FreeNAS Nightlies
  • Needs Merging changed from Yes to No

Also available in: Atom PDF