Project

General

Profile

Bug #32

LAN/LAGG Management from GUI

Added by Mahdi - about 9 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Important
Assignee:
Xin Li
Category:
Middleware
Target version:
-
Seen in:
Severity:
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When I go to interfaces I don't see any of my NICs although I know all my intel nics are compatible and working. Please make it easy to configure LAGG/LACP from the GUI as well like the previous version of [[FreeNAS]].

Associated revisions

Revision 6d528230 (diff)
Added by Alexander Motin over 3 years ago

6418 zpool should have a label clearing command Reviewed by: Yuri Pankov <yuri.pankov@nexenta.com> Reviewed by: Matthew Ahrens <mahrens@delphix.com> Reviewed by: George Wilson <george.wilson@delphix.com> Author: Will Andrews <will@firepipe.net> Closes #83 Closes #32

Revision 6d528230 (diff)
Added by Alexander Motin over 3 years ago

6418 zpool should have a label clearing command Reviewed by: Yuri Pankov <yuri.pankov@nexenta.com> Reviewed by: Matthew Ahrens <mahrens@delphix.com> Reviewed by: George Wilson <george.wilson@delphix.com> Author: Will Andrews <will@firepipe.net> Closes #83 Closes #32

Revision 9a9b9b4f (diff)
Added by Alexander Motin over 3 years ago

6418 zpool should have a label clearing command Reviewed by: Yuri Pankov <yuri.pankov@nexenta.com> Reviewed by: Matthew Ahrens <mahrens@delphix.com> Reviewed by: George Wilson <george.wilson@delphix.com> Author: Will Andrews <will@firepipe.net> Closes #83 Closes #32

Revision 9a9b9b4f (diff)
Added by Alexander Motin over 3 years ago

6418 zpool should have a label clearing command Reviewed by: Yuri Pankov <yuri.pankov@nexenta.com> Reviewed by: Matthew Ahrens <mahrens@delphix.com> Reviewed by: George Wilson <george.wilson@delphix.com> Author: Will Andrews <will@firepipe.net> Closes #83 Closes #32

Revision 6dcdb61a (diff)
Added by Alexander Motin over 3 years ago

MFV r297760: 6418 zpool should have a label clearing command Reviewed by: Yuri Pankov <yuri.pankov@nexenta.com> Reviewed by: Matthew Ahrens <mahrens@delphix.com> Reviewed by: George Wilson <george.wilson@delphix.com> Author: Will Andrews <will@firepipe.net> Closes #83 Closes #32 openzfs/openzfs@9663688425131744221ea99f9e66b9ed964492ae FreeBSD already had `zpool labelclear` functionality, so this is mostly just a diff reduction. MFC after: 1 month

Revision 6dcdb61a (diff)
Added by Alexander Motin over 3 years ago

MFV r297760: 6418 zpool should have a label clearing command Reviewed by: Yuri Pankov <yuri.pankov@nexenta.com> Reviewed by: Matthew Ahrens <mahrens@delphix.com> Reviewed by: George Wilson <george.wilson@delphix.com> Author: Will Andrews <will@firepipe.net> Closes #83 Closes #32 openzfs/openzfs@9663688425131744221ea99f9e66b9ed964492ae FreeBSD already had `zpool labelclear` functionality, so this is mostly just a diff reduction. MFC after: 1 month

Revision abf9aa9b (diff)
Added by Alexander Motin over 3 years ago

MFV r297760: 6418 zpool should have a label clearing command Reviewed by: Yuri Pankov <yuri.pankov@nexenta.com> Reviewed by: Matthew Ahrens <mahrens@delphix.com> Reviewed by: George Wilson <george.wilson@delphix.com> Author: Will Andrews <will@firepipe.net> Closes #83 Closes #32 openzfs/openzfs@9663688425131744221ea99f9e66b9ed964492ae FreeBSD already had `zpool labelclear` functionality, so this is mostly just a diff reduction. MFC after: 1 month git-svn-id: svn+ssh://svn.freebsd.org/base/head@297763 ccf9f872-aa2e-dd11-9fc8-001c23d0bc1f

Revision abf9aa9b (diff)
Added by Alexander Motin over 3 years ago

MFV r297760: 6418 zpool should have a label clearing command Reviewed by: Yuri Pankov <yuri.pankov@nexenta.com> Reviewed by: Matthew Ahrens <mahrens@delphix.com> Reviewed by: George Wilson <george.wilson@delphix.com> Author: Will Andrews <will@firepipe.net> Closes #83 Closes #32 openzfs/openzfs@9663688425131744221ea99f9e66b9ed964492ae FreeBSD already had `zpool labelclear` functionality, so this is mostly just a diff reduction. MFC after: 1 month git-svn-id: svn+ssh://svn.freebsd.org/base/head@297763 ccf9f872-aa2e-dd11-9fc8-001c23d0bc1f

Revision fa7200b9 (diff)
Added by Alexander Motin over 3 years ago

MFC r297763: MFV r297760: 6418 zpool should have a label clearing command Reviewed by: Yuri Pankov <yuri.pankov@nexenta.com> Reviewed by: Matthew Ahrens <mahrens@delphix.com> Reviewed by: George Wilson <george.wilson@delphix.com> Author: Will Andrews <will@firepipe.net> Closes #83 Closes #32 openzfs/openzfs@9663688425131744221ea99f9e66b9ed964492ae FreeBSD already had `zpool labelclear` functionality, so this is mostly just a diff reduction.

Revision fa7200b9 (diff)
Added by Alexander Motin over 3 years ago

MFC r297763: MFV r297760: 6418 zpool should have a label clearing command Reviewed by: Yuri Pankov <yuri.pankov@nexenta.com> Reviewed by: Matthew Ahrens <mahrens@delphix.com> Reviewed by: George Wilson <george.wilson@delphix.com> Author: Will Andrews <will@firepipe.net> Closes #83 Closes #32 openzfs/openzfs@9663688425131744221ea99f9e66b9ed964492ae FreeBSD already had `zpool labelclear` functionality, so this is mostly just a diff reduction.

Revision b70f2e53 (diff)
Added by Alexander Motin over 3 years ago

MFC r297763: MFV r297760: 6418 zpool should have a label clearing command Reviewed by: Yuri Pankov <yuri.pankov@nexenta.com> Reviewed by: Matthew Ahrens <mahrens@delphix.com> Reviewed by: George Wilson <george.wilson@delphix.com> Author: Will Andrews <will@firepipe.net> Closes #83 Closes #32 openzfs/openzfs@9663688425131744221ea99f9e66b9ed964492ae FreeBSD already had `zpool labelclear` functionality, so this is mostly just a diff reduction. (cherry picked from commit fa7200b98d2581e8cc2cf56be339ca37fb678277)

Revision b70f2e53 (diff)
Added by Alexander Motin over 3 years ago

MFC r297763: MFV r297760: 6418 zpool should have a label clearing command Reviewed by: Yuri Pankov <yuri.pankov@nexenta.com> Reviewed by: Matthew Ahrens <mahrens@delphix.com> Reviewed by: George Wilson <george.wilson@delphix.com> Author: Will Andrews <will@firepipe.net> Closes #83 Closes #32 openzfs/openzfs@9663688425131744221ea99f9e66b9ed964492ae FreeBSD already had `zpool labelclear` functionality, so this is mostly just a diff reduction. (cherry picked from commit fa7200b98d2581e8cc2cf56be339ca37fb678277)

History

#1 Updated by Dylan Perry about 9 years ago

++

#2 Updated by Josh Paetzel about 9 years ago

Could you do an ifconfig -a from the console and paste the output to this ticket please?

LAGG was removed from the GUI for the beta because it wasn't fully hooked up, but it will be in the release.

#3 Updated by Mahdi - about 9 years ago

Replying to [comment:3 jpaetzel]:

Could you do an ifconfig -a from the console and paste the output to this ticket please?

LAGG was removed from the GUI for the beta because it wasn't fully hooked up, but it will be in the release.

What I want to do is detailed here: http://www.freebsd.org/doc/handbook/network-aggregation.html

Create a lagg port using LACP with jumbo frames enabled. However, when I send the command ifconfig lagg0 create
I get invalid argument.

Would be great if I could do this using the GUI... but I can't even seem to do it using the shell.

Here is my output for ifconfig -a:

[root@freenas ~]# ifconfig -a
igb0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=13b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,TSO4>
ether 00:1b:21:66:9c:74
inet 10.0.0.135 netmask 0xffffff00 broadcast 10.0.0.255
media: Ethernet autoselect (1000baseT <full-duplex>)
status: active
igb1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=13b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,TSO4>
ether 00:1b:21:66:9c:75
media: Ethernet autoselect
status: no carrier
em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=219b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MAGIC>
ether 00:25:90:04:19:4a
media: Ethernet autoselect
status: no carrier
em1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=219b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MAGIC>
ether 00:25:90:04:19:4b
inet 10.0.0.122 netmask 0xffffff00 broadcast 10.0.0.255
media: Ethernet autoselect (1000baseT <full-duplex>)
status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=3<RXCSUM,TXCSUM>
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5
inet6 ::1 prefixlen 128
inet 127.0.0.1 netmask 0xff000000
nd6 options=3<PERFORMNUD,ACCEPT_RTADV>

#4 Updated by Josh Paetzel about 9 years ago

The issue with creating a lagg manually is that device lagg isn't in the kernel, and the if_lagg.ko module isn't available.

The issue with your interfaces not showing up in the GUI is a bit more concerning because I don't understand why that's not working.

#5 Updated by Mahdi - about 9 years ago

And when I try to add the interface, it sees the nics but then crashes when added and I loose access to the Nic.

All my nics are intel and my board is a supermicro X7SPE-HF.

#6 Updated by raulfg - about 9 years ago

++

#7 Updated by Xin Li about 9 years ago

A prototype was implemented last Wednesday. Need further polishing but I'd take this for now.

#9 Updated by Jordan Hubbard over 4 years ago

  • Target version deleted (2)

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

Commit: 7906477c65b906306ffaaad3053ed37f543ba62b
https://github.com/pcbsd/freebsd-ports/commit/7906477c65b906306ffaaad3053ed37f543ba62b
Author: Kris Moore <>
Date: 2015-09-18 (Fri, 18 Sep 2015)

Log Message:
-----------
Merge pull request #32 from Sp1l/master

Fixes for build with No-SSLv3 2015-09-18

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

Commit: eac0d507dbc63514e8124244009d68a5a0786687
https://github.com/pcbsd/freebsd-ports/commit/eac0d507dbc63514e8124244009d68a5a0786687
Author: pawel <>
Date: 2015-11-24 (Tue, 24 Nov 2015)

Log Message:
-----------
Update to version 0.2.0

Changelog:
- quiet batch mode (not available on OSX) - #13
- bugfixes in Napisy24 engine - #23
- icons placed at directories according to their sizes - #24
- HiDPI display awareness (OSX) - #27
- support for paths containing special characters (Windows) - #28
- bugfixed SRT conversion adding empty lines to resulting file (Windows) - #29
- application self-closing in batch mode (OSX) - #31
- added version information to .exe file (Windows) - #32
- bugfixes in file encoding detection (UTF-8 with BOM amongst others) - #34
- preserving original file encoding during subtitle format conversion
- bugfixed backup language support - #36

#12 Updated by iXsystems Bot almost 2 years ago

Commit: f957fa0e1bdb9502dbbe0cc0eeba8716a1f29582
https://github.com/freenas/samba/commit/f957fa0e1bdb9502dbbe0cc0eeba8716a1f29582
Author: Timur Bakeyev <>
Date: 2018-02-16 (Fri, 16 Feb 2018)

Log Message:
-----------
Fix the regression which was caused by the failure of memory (#32)

(re)allocation in case when attribute size in get_xattr_value()
was 0 or streams_xattr_ftruncate() received 0 as an argument.

Also available in: Atom PDF