Project

General

Profile

Bug #3205

Display issues with message log window in Chromium on PC-BSD

Added by Anonymous about 7 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
No priority
Assignee:
William Grzybowski
Category:
GUI (new)
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I've been having a number of odd display issues with the message log box in Chromium Version 29.0.1547.65 (220622) on PC-BSD 9.1. I have enclosed screenshots below. Basically, the window is tied to the right side of the screen. If you drag it right, it compresses slightly to a minimum width against the right side and then goes off the right side, but snaps back when you release the mouse. If you drag it left, it gets wider and wider (to about the width of the longest line in the log) while remaining tied to the right side. Dragging further left makes it detach from the right side, but it resets back to the right side after releasing the drag.

This is merely a display issue - as far as I can tell the actual information displayed is not impacted. I've observed this bug in many past versions of FreeNAS, though I can't be sure exactly when it started.

DraggedMoreLeft.png (92.5 KB) DraggedMoreLeft.png Anonymous, 09/24/2013 06:23 PM
DraggedLeft.png (148 KB) DraggedLeft.png Anonymous, 09/24/2013 06:23 PM
DraggingFurtherLeft.png (89.7 KB) DraggingFurtherLeft.png Anonymous, 09/24/2013 06:23 PM
DraggingRight.png (174 KB) DraggingRight.png Anonymous, 09/24/2013 06:23 PM
FreeNASLogWindowInitial.png (166 KB) FreeNASLogWindowInitial.png Anonymous, 09/24/2013 06:23 PM
ResetAfterFurtherLeft.png (89.1 KB) ResetAfterFurtherLeft.png Anonymous, 09/24/2013 06:23 PM
ResetAfterDraggingRight.png (169 KB) ResetAfterDraggingRight.png Anonymous, 09/24/2013 06:23 PM
freenasconsolelong.png (88.5 KB) freenasconsolelong.png pathological case Anonymous, 11/26/2013 11:16 PM
54
55
56
57
58
59
60
158

Associated revisions

Revision 08be6ed7 (diff)
Added by William Grzybowski over 6 years ago

Word wrap the console messages Ticket: #3205

History

#1 Updated by Josh Paetzel about 7 years ago

  • Assignee set to William Grzybowski

William, can you reproduce this on Chromium for another OS? This may be a PC-BSD issue.

#2 Updated by William Grzybowski about 7 years ago

No, it seems to be working fine on my end.

Chromium 28 and PCBSD. Unless I did not understand the issue (dragging the dialog to the right).

#3 Updated by Jordan Hubbard about 7 years ago

  • Status changed from Unscreened to Closed: Cannot reproduce
  • Assignee changed from William Grzybowski to Anonymous

BRB: We can't reproduce this one. Old version of Chrome?

#4 Updated by Anonymous almost 7 years ago

158

I just reproduced this again in Chromium Version 30.0.1599.101 (227552) and FreeNAS-9.2.0-RC-20131126. The behavior only appears when there's a line in /var/log/messages longer than the width of the window. To make this happen, I ran 'echo aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa >>/var/log/messages' from the shell. This also caused the line to extend outside the footer window, though obviously that's a pathological case.

#5 Updated by Anonymous almost 7 years ago

  • Assignee changed from Anonymous to William Grzybowski

#6 Updated by William Grzybowski almost 7 years ago

Can you make a video like James does? :)

I can reproduce the bug in footer window, not in the shell.

I type echo aaaa*1000 >> /var/log/messages and nothing happens.

#7 Updated by Anonymous almost 7 years ago

Please see the video at sj-storage/Marketing/Ben/FreeNASLogWindowStretch.ogv

#8 Updated by William Grzybowski over 6 years ago

  • Status changed from Screened to Resolved

#9 Updated by Dru Lavigne almost 3 years ago

  • Target version set to Master - FreeNAS Nightlies

Also available in: Atom PDF