Project

General

Profile

Bug #32055

Remove warning that vfs_full_audit may cause transfer problems

Added by Andrew Walker about 1 year ago. Updated 8 months ago.

Status:
Done
Priority:
No priority
Assignee:
Timur Bakeyev
Category:
Services
Target version:
Seen in:
Severity:
Low
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Enabling full audit without properly configuring it can cause severe performance issues. This isn't specific specific to Windows 10.

Full Audit.png (83.7 KB) Full Audit.png Andrew Walker, 04/13/2018 01:08 PM
16572

Associated revisions

Revision 70cfbf1a (diff)
Added by Timur I. Bakeyev 10 months ago

Remove warning that vfs_full_audit may cause transfer problems with the
Windows 10. The issue isn't W10 specific and was caused by the high
additional load on the server with the default setting of "all" for
logging of all file operations. The default has been changed to be
"none".

Ticket: #32055

Revision adba632f
Added by Timur Bakeyev 10 months ago

Merge pull request #58 from freenas/FIX-32055-master

Fix #32055 master

Ticket: #32055

Revision d1cd85ad (diff)
Added by Timur I. Bakeyev 9 months ago

Remove warning that vfs_full_audit may cause transfer problems with the
Windows 10. The issue isn't W10 specific and was caused by the high
additional load on the server with the default setting of "all" for
logging of all file operations. The default has been changed to be
"none".

Ticket: #32055
(cherry picked from commit 70cfbf1a70b82668dc775b1b6a5e8c556f5b02f9)

Revision 207913a7
Added by Timur Bakeyev 9 months ago

Merge pull request #1570 from freenas/FIX-32055-stable

Remove warning that vfs_full_audit may cause transfer problems with the Windows 10. The issue isn't W10 specific and was caused by the high additional load on the server with the default setting of "all" for logging of all file operations. The default has been changed to be "none".

Ticket: #32055

History

#1 Updated by Dru Lavigne about 1 year ago

  • Status changed from Unscreened to Blocked
  • Assignee changed from John Hixson to Timur Bakeyev
  • Target version set to 11.2-RC2
  • Reason for Blocked set to Need verification

Andrew: what should it say instead? Or should the popup be disabled entirely?

#2 Updated by Nick Wolff about 1 year ago

  • Severity set to Low

#3 Updated by Timur Bakeyev about 1 year ago

Andrew, I'm not sure what to do here and what transfer issues are meant in the message.

If that's the latency issue we should just generalize message saying that "you gonna suffer!"

But if transfer issues mean dropped sessions or broken files - that's another story. It would be nice to find out where that message comes from.

#4 Updated by Timur Bakeyev 12 months ago

  • Reason for Blocked changed from Need verification to Need additional information from Author

#5 Updated by Timur Bakeyev 12 months ago

  • Status changed from Blocked to In Progress
  • Reason for Blocked deleted (Need additional information from Author)

Andrew pointed me to the origin of the problem: https://forums.freenas.org/index.php?threads/strange-behaviour-of-my-smb-cifs-shares-insufficient-system-resources.44870/

I think the right fix would be to make default "none" for the vfs_full_audit for the successful operations. And remove the warning in the GUI.

#6 Updated by Timur Bakeyev 10 months ago

Ok, I have a fix for vfs_full_audit module and clean up of the dialogue. Need to commit those.

#7 Updated by Timur Bakeyev 10 months ago

  • Status changed from In Progress to Ready for Testing

#8 Updated by Dru Lavigne 10 months ago

  • Status changed from Ready for Testing to In Progress
  • Target version changed from 11.2-RC2 to 11.2-BETA2

#9 Updated by Timur Bakeyev 10 months ago

  • Status changed from In Progress to Ready for Testing

Both PRs have been committed to MASTER and ready for testing. Not sure, if there is a similar message in the new UI, that has to be checked with Erin, I guess.

#10 Updated by Dru Lavigne 10 months ago

  • Subject changed from Stop warning that vfs_full_audit doesn't work with Windows 10. to Remove warning that vfs_full_audit may cause transfer problems
  • Needs Merging changed from Yes to No

#11 Updated by Timur Bakeyev 10 months ago

Ok, new UI doesn't have this warning at all.

#13 Updated by Dru Lavigne 9 months ago

  • Target version changed from 11.2-BETA2 to 11.1-U6

#15 Updated by Timur Bakeyev 9 months ago

  • Status changed from Ready for Testing to In Progress

#17 Updated by Timur Bakeyev 9 months ago

  • Category changed from OS to Services
  • Status changed from In Progress to Ready for Testing

11.1-stable is also ready for testing

#18 Updated by Dru Lavigne 9 months ago

  • Needs Doc changed from Yes to No

#19 Updated by Bonnie Follweiler 8 months ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Passed Testing in FreeNAS-11.1-U6-INTERNAL4

#20 Updated by Dru Lavigne 8 months ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF