Project

General

Profile

Bug #32094

SMB Service restarts

Added by Thomas Rottig over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
John Hixson
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When transfering files via SMB the Service restarts itself breaking the transfer.
I thought this might be related to joining an AD domain but still happens after disableing AD membership.

NFS transfer is not impacted so it should be specifically SMB related


Related issues

Related to FreeNAS - Bug #33453: Fix unnecessary AD restarts caused by enabling service monitorDone

History

#1 Updated by Thomas Rottig over 2 years ago

  • File debug-avoton-20180414094744.txz added
  • Private changed from No to Yes

#2 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Timur Bakeyev
  • Target version set to 11.2-RC2
  • Seen in changed from Unspecified to 11.1-U4

#3 Updated by Thomas Rottig over 2 years ago

Hi,
is there anything else you need to work on this?
Or is all clear from the debug bundle?

Thanks,
regards,
thomas

#4 Updated by Timur Bakeyev over 2 years ago

  • Status changed from Unscreened to Screened

Hi, Thomas!

From the log I can see that smbd process is crashing pretty frequently, I'm trying to squeeze more info from the debug log, but eventually I'll probably will need more information form you and, maybe, access to your system if it's OK with you.

#5 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Severity set to New

#6 Updated by John Hixson over 2 years ago

  • Status changed from Screened to Closed

No response from user, so closing this out

#7 Updated by Thomas Rottig over 2 years ago

Sorry didn't think a response was required as i assumed I would be contacted whenever the plans to access the box would get more imminent

#8 Updated by Dru Lavigne over 2 years ago

  • Status changed from Closed to Unscreened
  • Assignee changed from Timur Bakeyev to John Hixson

#9 Updated by Thomas Rottig over 2 years ago

How likely is it that deploying a new VM and loading the old config will fix the issue?

#10 Updated by John Hixson over 2 years ago

  • Status changed from Unscreened to Screened

#11 Updated by John Hixson over 2 years ago

Briefly looking at your logs, I see a lot of this:

[2017/02/03 12:51:31.125071, 1] ../source3/libads/ldap.c:553(ads_find_dc)
ads_find_dc: name resolution for realm 'ad.voelligegal.de' (domain 'VEG') failed: NT_STATUS_NO_LOGON_SERVERS

and this:

Apr 14 11:43:41 avoton sshd29366: pam_winbind(sshd): valid_user: wbcGetpwnam gave WBC_ERR_DOMAIN_NOT_FOUND

Which leads me to believe you are having DNS problems and/or misconfigured Active Directory. Are you still having problems with this? Do you have AD monitoring enabled?

#12 Updated by John Hixson over 2 years ago

  • Status changed from Screened to In Progress

#13 Updated by John Hixson over 2 years ago

  • Status changed from In Progress to Blocked

#14 Updated by Dru Lavigne over 2 years ago

  • Reason for Blocked set to Need additional information from Author

#15 Updated by Thomas Rottig over 2 years ago

The box is at my remote backup location which is connected via VPN/DYNDNS service. The PDC is only at my local place and I had some weird network issues lately which might explain the numerous AD issues.
Before I opened the bug I have tried checking basics myself - at this time AD has been working.
O/C it might be a follow up issue of having those AD issues, but it happens quite quickly after a restart so it shouldnt be related to an overrun/build up issue.

I am not sure when exactly this started - the box in question is my backup/remote sync box and usually I only access it by nfs.
I recently had to do maintenance on my local box and thus movie sharing out to the family didn't meet the expected availability levels;) - so I set up a load balancer to ensure smb availability for movie streaming. The remote box turned out to be horribly slow and break off all the time which turned out to be the service issues...

#16 Updated by Thomas Rottig over 2 years ago

  • File debug-avoton-20180620230825.tgz added

So I just recreated the issue after a longer network outage.
First I reenabled AD which I verified by being able to access a share via an AD User.
Then I started copying a file and smb crashed again.

I then saw error messages that AD is down too so this seems to be an effect rather than the cause.

PFA a new debug bundle.

#17 Updated by Dru Lavigne over 2 years ago

  • Status changed from Blocked to Screened
  • Reason for Blocked deleted (Need additional information from Author)

#18 Updated by John Hixson over 2 years ago

  • Status changed from Screened to Closed

Please disable AD service monitoring, then reboot. This should fix your issues.

#19 Updated by Dru Lavigne over 2 years ago

  • File deleted (debug-avoton-20180414094744.txz)

#20 Updated by Dru Lavigne over 2 years ago

  • File deleted (debug-avoton-20180620230825.tgz)

#21 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.2-RC2 to N/A
  • Private changed from Yes to No
  • Reason for Closing set to Duplicate Issue

#22 Updated by Dru Lavigne over 2 years ago

  • Related to Bug #33453: Fix unnecessary AD restarts caused by enabling service monitor added

Also available in: Atom PDF