Project

General

Profile

Bug #32106

/usr/local/etc/rc.d/nut: WARNING: $nut_upsshut is not set properly - see rc.conf(5)

Added by Carl Bernstein over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Benno Rice
Category:
Hardware
Target version:
Seen in:
Severity:
Low
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
No
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Recieving the following error when starting UPS service on 11.1U4.

"/usr/local/etc/rc.d/nut: WARNING: $nut_upsshut is not set properly - see rc.conf(5)."

tail -f /var/log/messages :

Apr 14 10:48:41 freenas upsd[37853]: mainloop: Interrupted system call
Apr 14 10:48:41 freenas root: /usr/local/etc/rc.d/nut: WARNING: $nut_upsshut is not set properly - see rc.conf(5).
Apr 14 10:48:41 freenas upsmon[37876]: upsmon parent: read

upsc ups@localhost:

battery.charge: 100
battery.charge.warning: 20
battery.runtime: 550
battery.type: PbAc
device.mfr: Emerson Network Power
device.model: Liebert PSA4
device.serial:
device.type: ups
driver.name: usbhid-ups
driver.parameter.pollfreq: 30
driver.parameter.pollinterval: 2
driver.parameter.port: /dev/ugen5.2
driver.parameter.synchronous: no
driver.version: 2.7.4
driver.version.data: Belkin/Liebert HID 0.17
driver.version.internal: 0.41
ups.mfr: Emerson Network Power
ups.model: Liebert PSA4
ups.productid: 0001
ups.serial:
ups.status: OL
ups.vendorid: 10af


Related issues

Is duplicate of FreeNAS - Bug #31400: Silence warning about nut_upsshut not being set when it is disabledDone

History

#1 Updated by Dru Lavigne over 3 years ago

  • Private changed from No to Yes

Carl: please attach a debug (System -> Advanced -> Save Debug) to this ticket.

#2 Updated by Carl Bernstein over 3 years ago

  • File debug-freenas-20180415123820.tgz added

#3 Updated by Dru Lavigne over 3 years ago

  • Assignee changed from Release Council to Alexander Motin
  • Target version set to 11.2-RC2

#4 Updated by Alexander Motin over 3 years ago

  • Assignee changed from Alexander Motin to Benno Rice

#5 Updated by Benno Rice over 3 years ago

  • Is duplicate of Bug #31400: Silence warning about nut_upsshut not being set when it is disabled added

#6 Updated by Benno Rice over 3 years ago

  • Status changed from Unscreened to Ready for Testing

#7 Updated by Dru Lavigne over 3 years ago

  • File deleted (debug-freenas-20180415123820.tgz)

#8 Updated by Dru Lavigne over 3 years ago

  • Status changed from Ready for Testing to Closed
  • Target version changed from 11.2-RC2 to N/A
  • Private changed from Yes to No
  • Reason for Closing set to Duplicate Issue

Also available in: Atom PDF