Project

General

Profile

Bug #32262

Sorting bug fixed in ISCSITargetToExtent

Added by Caleb St. John over 1 year ago. Updated about 1 year ago.

Status:
Done
Priority:
Expected
Assignee:
Waqar Ahmed
Category:
Middleware
Target version:
Seen in:
Severity:
Low Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Related projects 1 project

Description

On 11.1-U4, if you have > 1 entry in the "Associated Targets" section in the webUI and you try to Sort the associated targets by clicking on the column it throws out this error message:

Unable to load /api/v1.0/services/iscsi/targettoextent/?parent=null&sort(+iscsi_target) status: 500

Associated revisions

Revision 694464fb (diff)
Added by Waqar Ahmed about 1 year ago

Sorting bug fixed in API 1.0
Ticket: #32262

History

#1 Updated by Dru Lavigne about 1 year ago

  • Project changed from TrueNAS to FreeNAS
  • Category changed from GUI to Middleware
  • Assignee changed from Release Council to William Grzybowski
  • Target version changed from TrueNAS 11.1-U5 to 11.1-U5
  • Migration Needed deleted (No)
  • Hide from ChangeLog deleted (No)
  • Support Department Priority deleted (0)

#2 Updated by William Grzybowski about 1 year ago

  • Status changed from Unscreened to Screened
  • Target version changed from 11.1-U5 to 11.2-RC2
  • Severity changed from Med High to Low Medium

I disagree this is a regression and High severity. I believe this bug has been there for quite some time and does not degrade usage of the UI to that point. Correct me if I am wrong.

#3 Updated by Caleb St. John about 1 year ago

  • Priority changed from Regression to Expected

You're right. This has been happening since at least 11.0-U6 so this is not a regression and can be punted for a later release.

Thanks!

#4 Updated by William Grzybowski about 1 year ago

  • Status changed from Screened to Unscreened
  • Assignee changed from William Grzybowski to Waqar Ahmed

Waqar, could you investigate this, please?

If it turns out to be too much hassle perhaps just disable sorting on that column.

#5 Updated by Waqar Ahmed about 1 year ago

  • Status changed from Unscreened to In Progress

#6 Updated by Waqar Ahmed about 1 year ago

  • Status changed from In Progress to Ready for Testing

#7 Updated by Dru Lavigne about 1 year ago

  • Subject changed from Unable to load /api/v1.0 error message to Sorting bug fixed in ISCSITargetToExtent
  • Target version changed from 11.2-RC2 to 11.2-BETA1

#8 Updated by Paul Walker about 1 year ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Sorting works with one target as expected, no errors seen.

#9 Updated by Dru Lavigne about 1 year ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF