Project

General

Profile

Bug #3236

Cannot assign ipv6 addresses to existing jail configuration

Added by William Jagels almost 7 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
John Hixson
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

The jail IP configuration page does not include an advanced options button as it does in [[Jails_Configuration]].

This is on dedicated hardware x64 architecture. IPv6 addressing works for the main gui page.

History

#1 Updated by William Jagels almost 7 years ago

#2 Updated by Josh Paetzel almost 7 years ago

  • Assignee set to William Grzybowski
  • Target version set to 49

This is intentional - IPv6 does not work properly in jails currently and was therefore deliberately disabled; IPv6 support is a feature for a future release (this is not the only IPv6 related thing that is broken!).

#3 Updated by Jordan Hubbard almost 7 years ago

  • Status changed from Unscreened to Investigation

BRB: This actually does behave correctly for now since IPv6 is broken in jails and hence deliberately disabled, but we will keep this bug in investigation because we would like this to work someday, as part of a larger "support IPv6 properly" initiative.

#4 Updated by William Grzybowski almost 7 years ago

  • Assignee changed from William Grzybowski to John Hixson

Assigning to John as he has been responsible for jails changes. Let me know if there is something I should do instead.

#5 Updated by John Hixson almost 7 years ago

Yeah, let's shoot for fixing ipv6 in 10 ;-)

#6 Updated by Alec Edworthy over 6 years ago

I note that the Advanced button has reappeared (in 9.2.1.3 perhaps since 9.2.1.1 IIRC) with IPv6 address boxes present. Does this mean that some work has been done on getting IPv6 working in jails? From what I can see IPv6 works if you disable VIMAGE but if that is enabled then you loose IPv6 connectivity which appears to be because there is nothing listening on the FreeNAS host with the IPv6 address the jail has been allocated and so packets cannot flow.

Is there an estimate on when we might see IPv6 working in jails please, and most interestingly for me IPv4 NAT alongside public IPv6 in jails?

Alec

#7 Updated by John Hixson about 6 years ago

  • Status changed from Investigation to Resolved

the Advanced section is there and IPv6 now works correctly.

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from 49 to N/A

Also available in: Atom PDF