Project

General

Profile

Bug #32373

Sort NFS shares by path in legacy UI

Added by Sebastien BLANCHET over 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

In the Legacy NFS Sharing UI, NFS shares can not be sorted by path when clicking on the column title.
All columns can be sorted except the Paths column.

The Windows Sharing UI is not affected by this issue.

Expected behavior

In NFS Sharing (Legacy) UI, when clicking on the column title Paths, it should sort paths by name

Step to reproduce:

  1. Go to Sharing | UNIX (NFS)
  2. Create two shares:
    • /mnt/tank1/foo
    • /mnt/tank1/bar
  3. Click on the column title Paths to sort in alphabetical order
  4. But nothing happens. The black arrow does not appear in the column title.

Notes

  • Other columns in NFS sharing UI work (Comment, All Directories, Read Only)
  • SMB sharing UI does not suffer this issue, all columns work
  • I have tested with many web browsers and I have the same wrong behavior:
    • Firefox 52.7.3 (64-bit), Linux
    • Google Chrome Version 65.0.3325.181 (Official Build) (64-bit), Linux
    • Microsoft Edge, Windows 10
    • Microsoft Internet Explorer 11, Windows 10
    • Firefox 59.0.2 (64 bits), Windows 10
    • Google Chrome Version 66.0.3359.117 (Official Build) (64-bit), Windows 10

Associated revisions

Revision 2de45e0a (diff)
Added by Sebastien BLANCHET about 2 years ago

fix(gui): make sortable the column for NFS paths Ticket: #32373

History

#1 Updated by Dru Lavigne over 2 years ago

  • Status changed from Unscreened to Closed
  • Target version set to N/A
  • Reason for Closing set to Not Applicable

Sebastien: this works correctly in the new UI which will be the default as of the next version.

#2 Updated by Sebastien BLANCHET about 2 years ago

  • Seen in changed from 11.1-U4 to 11.1-U6

I have proposed a patch to fix this issue.
The patch is only a single boolean to toggle, so I hope it could be accepted for the next FreeNAS release
because many users still prefer the old UI.

https://github.com/freenas/freenas/pull/1825

#3 Updated by Dru Lavigne about 2 years ago

  • Category changed from GUI (new) to Middleware
  • Status changed from Closed to In Progress
  • Assignee changed from Release Council to William Grzybowski
  • Reason for Closing deleted (Not Applicable)

#4 Updated by William Grzybowski about 2 years ago

  • Status changed from In Progress to Ready for Testing
  • Target version changed from N/A to 11.2-RC1

#5 Updated by Dru Lavigne about 2 years ago

  • Subject changed from Legacy UI - NFS Sharing: cannot sort NFS Shares by path to Sort NFS shares by path in legacy UI
  • Needs Merging changed from Yes to No

#7 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF