Project

General

Profile

Bug #32445

Boot Drive

Added by I m over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
No priority
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Seen in:
Severity:
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

*One of the drives (da0p1) in a boot mirror-0 failed. Now its name changed from da0p1 to 6219107099379840835 with a status REMOVED.

When I try to replace it from the GUI, I get the green message "Disk is being replaced" but nothing really get replaced.

When I try to detach it from the GUI, I get this error:*

Request Method: POST
Request URL: http://x.x.x.x/system/bootenv/pool/detach/6219107099379840835/
Software Version: FreeNAS-11.1-U4 (89e3d93bc)
Exception Type: ClientException
Exception Value:
[EINVAL] Failed to find vdev for 6219107099379840835
Exception Location: /usr/local/lib/python3.6/site-packages/middlewared/client/client.py in call, line 421
Server time: Wed, 18 Apr 2018 21:32:26 -0700

Environment:

Software Version: FreeNAS-11.1-U4 (89e3d93bc)
Request Method: POST
Request URL: http://x.x.x.x/system/bootenv/pool/detach/6219107099379840835/

Traceback:
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner
42. response = get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _legacy_get_response
249. response = self._get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response
178. response = middleware_method(request, callback, callback_args, callback_kwargs)
File "./freenasUI/freeadmin/middleware.py" in process_view
162. return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
23. return view_func(request, *args, **kwargs)
File "./freenasUI/system/views.py" in bootenv_pool_detach
543. c.call('boot.detach', label)
File "./freenasUI/system/views.py" in bootenv_pool_detach
543. c.call('boot.detach', label)
File "/usr/local/lib/python3.6/site-packages/middlewared/client/client.py" in call
421. raise ClientException(c.error, c.errno, c.trace, c.extra)

Exception Type: ClientException at /system/bootenv/pool/detach/6219107099379840835/
Exception Value: [EINVAL] Failed to find vdev for 6219107099379840835

Could you please assist me with this issue? Thank you.


Related issues

Is duplicate of FreeNAS - Bug #29277: Wait for zfs.pool.extend to complete so we can propagate errors when adding a mirrored USB driveDone

History

#1 Updated by I m over 1 year ago

  • Description updated (diff)

#2 Updated by I m over 1 year ago

  • Description updated (diff)
  • Private changed from No to Yes

#3 Updated by I m over 1 year ago

I found the solution.

I did some research and found out how to detach the bad disk from shell. I used the original disk name da0p1 and not 6219107099379840835. Then I was able to attach the new disk from the GUI.

I think this is a GUI bug.

Thank you.

#4 Updated by Dru Lavigne over 1 year ago

  • Category changed from Build system to Middleware
  • Assignee changed from Release Council to William Grzybowski
  • Target version set to 11.2-RC2

Over to the middleware team to handle the traceback.

#5 Updated by William Grzybowski over 1 year ago

  • Assignee changed from William Grzybowski to Vladimir Vinogradenko

Vladimir, wasnt that handled already in 11.2.?

#6 Updated by Vladimir Vinogradenko over 1 year ago

  • Status changed from Unscreened to Closed
  • Reason for Closing set to Duplicate Issue

#7 Updated by Vladimir Vinogradenko over 1 year ago

  • Is duplicate of Bug #29277: Wait for zfs.pool.extend to complete so we can propagate errors when adding a mirrored USB drive added

#8 Updated by Dru Lavigne over 1 year ago

  • Target version changed from 11.2-RC2 to N/A
  • Private changed from Yes to No

Also available in: Atom PDF