Project

General

Profile

Bug #32502

Fix smartd config not being generated

Added by Timothy Moore II about 1 year ago. Updated about 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Vladimir Vinogradenko
Category:
GUI (new)
Target version:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I'm testing the new UI with a FreeNAS system updated to the latest FreeNAS-11-Nightly version.
After rebooting the system, I navigated to the services page and discovered the SMART service was displaying a "Crashed" status. I attempted to restart it, but nothing seems to happen. After enabling console messages, this error is constantly displaying in the console:

/usr/local/etc/rc.d/smartd-daemon: WARNING: /usr/local/etc/smartd.conf is not readable.

Related issues

Has duplicate FreeNAS - Bug #32571: smartd_daemon is not runningClosed
Has duplicate FreeNAS - Bug #32574: smartd not starting - smartd.conf missingClosed2018-04-22

Associated revisions

Revision 1565d8b1 (diff)
Added by Vladimir Vinogradenko about 1 year ago

fix(smart): Fix smartd config not being generated

Ticket: #32502

Revision 04a6dec5 (diff)
Added by Vladimir Vinogradenko about 1 year ago

fix(smart): Fix smartd config not being generated

Ticket: #32502

History

#1 Updated by Erin Clark about 1 year ago

  • Assignee changed from Erin Clark to William Grzybowski

I think this might be a middleware bug, passing to william

#2 Updated by William Grzybowski about 1 year ago

  • Assignee changed from William Grzybowski to Vladimir Vinogradenko

#3 Updated by Vladimir Vinogradenko about 1 year ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Waiting for feedback

Timothy, please attach a debug (System -> Advanced -> Save Debug)

#4 Updated by Disk Didler about 1 year ago

Can confirm I also have this, (didn't even know, I just checked after finding this post)

NOTE: May be relevant, I'm using VMWare for testing, not a live PC, perhaps OP is the same? VMWare limitation?

Also, having difficulty saving a debug log, what's the best method?

#5 Updated by Timothy Moore II about 1 year ago

  • File debug.tgz added

Debug attached. I updated my testing system (physical hardware, no vm) and checked it again. Looks like the issue is still present on the system.

#6 Updated by Timothy Moore II about 1 year ago

  • File debug-freenas-20180424065527.tgz added

Sorry, debug file didn't generate properly, may be another bug in the new UI for me to track down :).

#7 Updated by Dru Lavigne about 1 year ago

  • Private changed from No to Yes

#8 Updated by Vladimir Vinogradenko about 1 year ago

  • Status changed from Blocked to Ready for Testing

#9 Updated by Dru Lavigne about 1 year ago

  • File deleted (debug-freenas-20180424065527.tgz)

#10 Updated by Dru Lavigne about 1 year ago

  • File deleted (debug.tgz)

#11 Updated by Dru Lavigne about 1 year ago

  • Subject changed from Services/SMART : smartd.conf is unreadable to Fix smartd config not being generated
  • Private changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#12 Updated by Janus Ng about 1 year ago

This bug affects the old GUI as well. Did it fix the old UI?

#13 Updated by Dru Lavigne about 1 year ago

Janus: this wasn't a UI bug but an underlying middleware bug (so yes, both UIs will benefit from the fix).

#14 Updated by Janus Ng about 1 year ago

11.2 is still weeks away.

Could the fix apply to 11.1-U5 instead as it fixes the issue on 11.1 as well?

#15 Updated by Vladimir Vinogradenko about 1 year ago

Janus, this bug was introduced in one of the latest nightlies, it never existed in 11.1. 11.1 had another issue, it has already been fixed and will be included in U5

#16 Updated by Vladimir Vinogradenko about 1 year ago

  • Has duplicate Bug #32571: smartd_daemon is not running added

#17 Updated by Vladimir Vinogradenko about 1 year ago

  • Has duplicate Bug #32574: smartd not starting - smartd.conf missing added

#18 Avatar?id=55038&size=24x24 Updated by Zackary Welch about 1 year ago

  • Reason for Blocked changed from Waiting for feedback to Need verification
  • Needs QA changed from Yes to No
  • Needs Doc changed from No to Yes

I'm unable to reproduced a crashed status on reboot or any error that the configuration file is unreadable. I do not know your particular settings though, but it seems this bug is fixed.

#19 Avatar?id=55038&size=24x24 Updated by Zackary Welch about 1 year ago

  • Reason for Closing set to Cannot Reproduce
  • Reason for Blocked deleted (Need verification)
  • Needs Doc changed from Yes to No

#20 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready for Testing to Done
  • Reason for Closing deleted (Cannot Reproduce)

Also available in: Atom PDF