Project

General

Profile

Bug #32571

smartd_daemon is not running

Added by Chris Ng almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Vladimir Vinogradenko
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

upgrade from 9 to 11.1 (os version FreeNAS-11-MASTER-201804220410). then the SMART service is not working and alert message "smartd_daemon is not running."

my system has 4 hdd and a usb flash drive booting device.
the SMART service status in new GUI is "crashed"

try to start the service manually but not working.
try to disable usb flash drive SMART but not working.


Related issues

Is duplicate of FreeNAS - Bug #32502: Fix smartd config not being generatedDone
Is duplicate of FreeNAS - Bug #34360: Document workaround for when SMART service refuses to start on U5Done

History

#1 Updated by Chris Ng almost 2 years ago

  • File debug-nghonas-20180422180516.txz added
  • Private changed from No to Yes

#2 Updated by Chris Ng almost 2 years ago

  • File debug-nghonas-20180423001132.tgz added

#3 Updated by Chris Ng almost 2 years ago

  • File deleted (debug-nghonas-20180423001132.tgz)

#4 Updated by Dru Lavigne almost 2 years ago

  • Assignee changed from Release Council to Vladimir Vinogradenko
  • Target version set to 11.2-RC2

Vlad: please double-check whether this scenario will be fixed by your recent SMART fixes or if it is a separate issue that still needs fixing.

#5 Updated by Vladimir Vinogradenko almost 2 years ago

  • Status changed from Unscreened to Closed
  • Reason for Closing set to Duplicate Issue

#6 Updated by Vladimir Vinogradenko almost 2 years ago

  • Is duplicate of Bug #32502: Fix smartd config not being generated added

#7 Updated by Dru Lavigne almost 2 years ago

  • File deleted (debug-nghonas-20180422180516.txz)

#8 Updated by Dru Lavigne almost 2 years ago

  • Target version changed from 11.2-RC2 to N/A
  • Private changed from Yes to No

#9 Updated by gear head almost 2 years ago

  • File debug-freenas11-20180531084833.tgz added
  • Severity set to New
  • Seen in changed from Unspecified to 11.1-U5

I just upgraded from 11.1U4 to 11.1U5 and started getting the smartd_daemon is not running message. I disable the service to stop the warning. Attached is the debug file.
My Hardware:
Gigabit switch | 2x2TB HD Mirrored | 8GB ram | Intel Celeron G1850
MSI Z87 Mpower | clients running win7x64 ultimate win10x64|
CIFS shares

#10 Updated by Dru Lavigne almost 2 years ago

  • File deleted (debug-freenas11-20180531084833.tgz)

#11 Updated by Dru Lavigne almost 2 years ago

  • Is duplicate of Bug #34360: Document workaround for when SMART service refuses to start on U5 added

#12 Updated by Dru Lavigne almost 2 years ago

Chris: please follow the progress of the duplicate ticket #34360.

Also available in: Atom PDF