Project

General

Profile

Bug #32688

Check for updates cannot be cancelled

Added by Warren Block over 2 years ago. Updated over 2 years ago.

Status:
Done
Priority:
Important
Assignee:
Erin Clark
Category:
GUI (new)
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

System/Update/Check Now does a search for new updates. There is no cancel button or way to stop the check. If the remote system is unavailable or there is some network connection issue, this will try forever with a "Please wait" message.

There should be an explicit Cancel button here, along with a timeout of 30 seconds or less.


Related issues

Related to FreeNAS - Bug #33066: In the New GUI; Clicking the Check Now button in the System->Update shows the latest update info but the screen is stick on the "please wait" messageClosed

Associated revisions

Revision 575e16d6 (diff)
Added by Erin Clark over 2 years ago

Close update check after error Ticket: #32688

Revision 9047f524 (diff)
Added by Erin Clark over 2 years ago

Add another loader close and use dialog service for error Ticket: #32688

History

#1 Updated by Erin Clark over 2 years ago

  • Assignee changed from Erin Clark to Vaibhav Chauhan

#2 Updated by Vaibhav Chauhan over 2 years ago

I think this is by design and Erin even commited a fix for disabling dialogue boxes

commit 78cc1303bb141106380ea073e02cfd703f4e44f8
Author: Erin Clark <erin@ixsystems.com>
Date:   Fri Mar 2 16:40:56 2018 -0800

    Hide close button on dialogs that aren't supposed to be closable (i.e. while updating)

diff --git a/src/app/pages/common/entity/entity-job/entity-job.component.ts b/src/app/pages/common/entity/entity-job/entity-job.component.ts
index ab7c8db2..954233d4 100644
--- a/src/app/pages/common/entity/entity-job/entity-job.component.ts
+++ b/src/app/pages/common/entity/entity-job/entity-job.component.ts
@@ -34,6 +34,10 @@ export class EntityJobComponent implements OnInit {
     if (this.data.title) {
       this.title = this.data.title;
     }
+
+    if (this.dialogRef.disableClose) {
+      this.showCloseButton = false;
+    }
   }

I will defer to erin for further comments on what needs to be done next, also I would like to know why this was disabled from the beginning.

#3 Updated by Vaibhav Chauhan over 2 years ago

  • Assignee changed from Vaibhav Chauhan to Erin Clark

#4 Updated by Erin Clark over 2 years ago

  • Assignee changed from Erin Clark to William Grzybowski
  • Severity set to New

Now that I think about it I don't know of a way to cancel it from the UI side, is it possible that update.check_available could just auto-time out if the server is not available, William?

#5 Updated by William Grzybowski over 2 years ago

  • Assignee changed from William Grzybowski to Erin Clark

It does eventually times out, nothing is forever.

However webui websocket client call timeout anything as it wishes, legacy UI does that.

You have the id of the ws call, you can throw an error if it didnt respond in 60 seconds or so.

#6 Updated by Erin Clark over 2 years ago

  • Status changed from Unscreened to In Progress
  • Assignee changed from Erin Clark to Lola Yang

Upon further investigation it seems the problem was more that the loader wasn't being closed upon error.

https://github.com/freenas/webui/pull/702

#7 Updated by Dru Lavigne over 2 years ago

  • Status changed from In Progress to Done
  • Assignee changed from Lola Yang to Erin Clark
  • Target version changed from 11.2-BETA1 to Master - FreeNAS Nightlies
  • Needs Merging changed from Yes to No

#8 Updated by Warren Block over 2 years ago

  • Related to Bug #33066: In the New GUI; Clicking the Check Now button in the System->Update shows the latest update info but the screen is stick on the "please wait" message added

Also available in: Atom PDF