Project

General

Profile

Bug #32757

Error creating share

Added by Andreas Larsson almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Release Council
Category:
Middleware
Target version:
Severity:
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Whenever i try to create a share on the nightly i get a message saying 'Montpoint' in the right corner followed from this message:

Request Method:     POST
Request URL:    http://192.168.1.101/legacy/admin/sharing/cifs_share/add/
Software Version:   FreeNAS-11-MASTER-201804280407 (3c092d9)
Exception Type:     ClientException
Exception Value:    

'mountpoint'

Exception Location:     /usr/local/lib/python3.6/site-packages/middlewared/client/client.py in call, line 435
Server time:    Sat, 28 Apr 2018 16:13:41 +0200

Environment:

Software Version: FreeNAS-11-MASTER-201804280407 (3c092d9)
Request Method: POST
Request URL: http://192.168.1.101/legacy/admin/sharing/cifs_share/add/

Traceback:
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner
  42.             response = get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _legacy_get_response
  249.             response = self._get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response
  178.             response = middleware_method(request, callback, callback_args, callback_kwargs)
File "./freenasUI/freeadmin/middleware.py" in process_view
  163.         return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
  23.                 return view_func(request, *args, **kwargs)
File "./freenasUI/freeadmin/options.py" in wrapper
  216.                 return self._admin.admin_view(view)(*args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/django/utils/decorators.py" in _wrapped_view
  149.                     response = view_func(request, *args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/django/views/decorators/cache.py" in _wrapped_view_func
  57.         response = view_func(request, *args, **kwargs)
File "./freenasUI/freeadmin/site.py" in inner
  142.             return view(request, *args, **kwargs)
File "./freenasUI/freeadmin/options.py" in add
  370.                     mf.save()
File "./freenasUI/middleware/form.py" in save
  55.         result = self.__save()
File "./freenasUI/middleware/form.py" in __save
  114.                     raise
File "./freenasUI/middleware/form.py" in __save
  109.                 return c.call(f"{self.middleware_plugin}.{self._middleware_action}", *args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/middlewared/client/client.py" in call
  435.             raise ClientException(c.error, c.errno, c.trace, c.extra)

Exception Type: ClientException at /legacy/admin/sharing/cifs_share/add/
Exception Value: 'mountpoint'

Request information
GET

No GET data
POST
Variable    Value
__all__     ''
cifs_path   '/mnt/Array0/Share/Tank'
cifs_name   'Tank'
cifs_comment    ''
cifs_default_permissions    'on'
cifs_browsable  'on'
cifs_hostsallow     ''
cifs_hostsdeny  ''
selecAt_from    'xattr_tdb'
cifs_vfsobjects     'streams_xattr'
cifs_storage_task   ''
cifs_auxsmbconf     ''
__form_id   'dialogForm_cifs_share'
__confirm   '1'

I did try it on the new UI as well with no luck, get the same 'mountpoint' but not any fancy error messages.

the system is baisicly clean, i installed the stable 11.1 some days ago and everything worked to well, i was able to set up datasets and shares... but i got very bored with all the non broken functions and opted in for nightlys, i'w been using nightly on the test bench for some time now and i HAVE been able to make shares but not any more it seems.

Anyone else get this?


Related issues

Is duplicate of FreeNAS - Bug #32766: Fix mountpoint traceback when creating sharesDone

History

#1 Updated by Dru Lavigne almost 2 years ago

  • Is duplicate of Bug #32766: Fix mountpoint traceback when creating shares added

#2 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Duplicate Issue

Andreas: this has already been reported, though you won't be able to see the other ticket until the dev is finished with the user's debug info.

#3 Updated by Andreas Larsson almost 2 years ago

Dru Lavigne wrote:

Andreas: this has already been reported, though you won't be able to see the other ticket until the dev is finished with the user's debug info.

Good to know ;)
Keep up the good work!

Also available in: Atom PDF