Project

General

Profile

Feature #33

Add Benchmarking to default package

Added by Mahdi - about 9 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Important
Assignee:
-
Category:
Middleware
Target version:
Estimated time:
Severity:
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

It'd be really great if we could easily benchmark our [[FreeNAS]] devices. Could you include Bonnie, ioZone and ioStat in the default install packages? It would be really great if output could be read from the GUI.

Nexenta does not include benchmarking with it's default install but it makes it very easy to add in... which could be a great option for FN8... not sure how that would work for an embedded system though.

History

#1 Updated by Luke Herbert about 9 years ago

I think this is a great idea, in my case it is ioZone which I really think would included and hooked up to the GUI (FreeNAS is storage solution). However this functionality was never included in [[FreeNAS]] 0.7 and for that reason I think it would be great to have it be part of version 8.1 and keep the goal that 8.0 only provides the functionality of 0.7.

#2 Updated by Neil MacLeod over 8 years ago

I would also include iperf, for testing/benchmarking the network which is of course a critical part of the overall NAS solution.

iperf came as standard on [[FreeNAS]] 0.7.2. There's no need for a GUI as (IMHO) the command line via ssh etc. is a perfectly adequate (indeed preferable) way to access this particular tool.

#3 Updated by Anonymous over 8 years ago

iozone is now present on the CLI in [[FreeNAS]] 8.0.1 builds, post-RC1.

Will add iperf to the build as well.

#4 Updated by Anonymous over 8 years ago

  • Status changed from Unscreened to Closed

iperf and iozone are both present in trunk s.t. they can be invoked on the CLI.

Going through and creating a GUI for this doesn't make sense -- if you know how to execute iozone/iperf, you should also know how properly invoke and interpret the respective results.

Marking fixed.

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

Commit: 46e89490f48fd6e022dce730a7bf8e3d3c16e0fb
https://github.com/pcbsd/freebsd-ports/commit/46e89490f48fd6e022dce730a7bf8e3d3c16e0fb
Author: Bernard Spil <>
Date: 2015-09-23 (Wed, 23 Sep 2015)

Log Message:
-----------
Merge pull request #33 from Sp1l/master

Fix build of some ports with No-SSLv3

#6 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

Commit: 3bd19b1310a12a6bae51db5d7ca2d6a6ed1aed17
https://github.com/pcbsd/freebsd-ports/commit/3bd19b1310a12a6bae51db5d7ca2d6a6ed1aed17
Author: truckman <>
Date: 2016-02-03 (Wed, 03 Feb 2016)

Log Message:
-----------
Upgrade net/nmsg to 0.11.0:

nmsg (0.11.0)

[ Henry Stern ]
  • Add an interval randomization option that randomizes the initial offset
    within the selected time interval. This functionality is exposed via the
    libnmsg nmsg_io_set_interval_randomized() function and the nmsgtool -R /
    --randomize command-line option (#27, #33).
  • Add documention for nmsgtool -j / --readjson and -J / --write-json
    command-line options (#26, #28).
  • Add PKG_CHECK_MODULES dependency on yajl >= 2.1.0 (#29, #31).
  • Make nmsgtool -k / --kicker work when combined with -c or -t, when
    producing output in JSON format (#25, #38).
  • Fix compiler warning [-Wtautological-compare] in
    _nmsg_msgmod_json_to_payload_load() (#36, #39).
  • Add nmsg_message_get_num_field_values(),
    nmsg_message_get_num_field_values_by_idx() functions (#5, #40).
[ Robert Edmonds ]
  • Remove the unused enum nmsg_modtype from the internal libnmsg API (#30).
  • Header file cleanups (#14, #34).
  • Rewrite nmsg_res_lookup() to use a switch, which eliminates a Clang
    warning (#14, #35).
  • Add a message filtering capability to the libnmsg I/O loop, including
    external filter module plugin and nmsgtool support (#41, #43, #44).
[ Mike Schiffman ]
  • Add yajl/ prefix to #include's of yajl headers (#37)

Pet portlint

Sponsored by: Farsight Security, Inc.

#7 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

Commit: 3bd19b1310a12a6bae51db5d7ca2d6a6ed1aed17
https://github.com/pcbsd/freebsd-ports/commit/3bd19b1310a12a6bae51db5d7ca2d6a6ed1aed17
Author: truckman <>
Date: 2016-02-03 (Wed, 03 Feb 2016)

Log Message:
-----------
Upgrade net/nmsg to 0.11.0:

nmsg (0.11.0)

[ Henry Stern ]
  • Add an interval randomization option that randomizes the initial offset
    within the selected time interval. This functionality is exposed via the
    libnmsg nmsg_io_set_interval_randomized() function and the nmsgtool -R /
    --randomize command-line option (#27, #33).
  • Add documention for nmsgtool -j / --readjson and -J / --write-json
    command-line options (#26, #28).
  • Add PKG_CHECK_MODULES dependency on yajl >= 2.1.0 (#29, #31).
  • Make nmsgtool -k / --kicker work when combined with -c or -t, when
    producing output in JSON format (#25, #38).
  • Fix compiler warning [-Wtautological-compare] in
    _nmsg_msgmod_json_to_payload_load() (#36, #39).
  • Add nmsg_message_get_num_field_values(),
    nmsg_message_get_num_field_values_by_idx() functions (#5, #40).
[ Robert Edmonds ]
  • Remove the unused enum nmsg_modtype from the internal libnmsg API (#30).
  • Header file cleanups (#14, #34).
  • Rewrite nmsg_res_lookup() to use a switch, which eliminates a Clang
    warning (#14, #35).
  • Add a message filtering capability to the libnmsg I/O loop, including
    external filter module plugin and nmsgtool support (#41, #43, #44).
[ Mike Schiffman ]
  • Add yajl/ prefix to #include's of yajl headers (#37)

Pet portlint

Sponsored by: Farsight Security, Inc.

#8 Updated by iXsystems Bot almost 2 years ago

Commit: 772aefeed2e5442fa6c3cd96909357da3bac1b11
https://github.com/freenas/samba/commit/772aefeed2e5442fa6c3cd96909357da3bac1b11
Author: Timur Bakeyev <>
Date: 2018-02-16 (Fri, 16 Feb 2018)

Log Message:
-----------
Fix the regression which was caused by the failure of memory (#33)

(re)allocation in case when attribute size in get_xattr_value()
was 0 or streams_xattr_ftruncate() received 0 as an argument.

(cherry picked from commit 3db7512d3b70e7e32044cd0022b92c2560c9c309)
Signed-off-by: Timur I. Bakeyev <>

Also available in: Atom PDF