Project

General

Profile

Bug #33294

Fix traceback when adding a LAGG

Added by thilo nesnidal 12 months ago. Updated 10 months ago.

Status:
Done
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hey guys, I have issues with establishing LACP link aggregation.

The GUI returns an error (see below) but the lagg0 interface shows up and is configurable if you ack the error message.
However the link never becomes active on an arista port-channel.

FreeNAS Version: FreeNAS-11.1-U4 (89e3d93bc).
FreeNAS adapter card is an Intel X520.

FreeNAS status error:
CRITICAL: May 4, 2018, 12:23 p.m. - These ports are not ACTIVE on LAGG interface lagg0: bxe0, bxe1. Please check cabling and switch

I've tried several settings and got arista support involved now. Any hint would be appreciated.

configuration on the Arista (already confirmed by Arista support):


localhost(config)#sh ver
Arista DCS-7050TX-48-F
Hardware version:    11.12
Serial number:       J********
System MAC address:  001c.7183.7b29

Software image version: 4.19.3F
Architecture:           i386
Internal build version: 4.19.3F-6971068.4193F
[..]

localhost(config)#sh port-channel 1
Port Channel Port-Channel1:
  No Active Ports
  Configured, but inactive ports:
       Port            Reason unconfigured        
    ------------------ ---------------------------
       Ethernet35/1    Waiting in LACP Negotiation
       Ethernet36/1    Waiting in LACP Negotiation

sh run:
[..]
interface Port-Channel1
   description LACP to FreeNAS
   switchport access vlan 101
   spanning-tree portfast
!
interface Ethernet35/1
   description LACP to FreeNAS IF01
   flowcontrol receive on
   switchport access vlan 101
   channel-group 1 mode active
   spanning-tree portfast
!
interface Ethernet36/1
   description LACP to FreeNAS IF02
   flowcontrol receive on
   switchport access vlan 101
   channel-group 1 mode active
   spanning-tree portfast
!

FreeNAS ifconfig output:


bxe0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
  options=527bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,WOL_MAGIC,VLAN_HWFILTER,VLAN_HWTSO>
   ether 00:0e:1e:5d:a3:d0
   hwaddr 00:0e:1e:5d:a3:d0
   nd6 options=9<PERFORMNUD,IFDISABLED>
   media: Ethernet autoselect (10Gbase-SR <full-duplex>)
   status: active

bxe1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
  options=527bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,WOL_MAGIC,VLAN_HWFILTER,VLAN_HWTSO>
   ether 00:0e:1e:5d:a3:d0
   hwaddr 00:0e:1e:5d:a3:d2
   nd6 options=9<PERFORMNUD,IFDISABLED>
   media: Ethernet autoselect (10Gbase-SR <full-duplex>)
   status: active

lagg0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
  options=527bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,WOL_MAGIC,VLAN_HWFILTER,VLAN_HWTSO>
   ether 00:0e:1e:5d:a3:d0
   inet 10.0.0.100 netmask 0xffffff00 broadcast 10.0.0.255
   nd6 options=9<PERFORMNUD,IFDISABLED>
   media: Ethernet autoselect
   status: active
   groups: lagg
   laggproto lacp lagghash l2,l3,l4
   laggport: bxe0 flags=0<>
   laggport: bxe1 flags=0<>

GUI error message when creating a LACP lagg0 Interface:


Request Method:    POST
Request URL:    http://192.168.10.100/admin/network/lagginterface/add/
Software Version:    FreeNAS-11.1-U4 (89e3d93bc)
Exception Type:    ClientException
Exception Value:   

[Errno 17] File exists

Exception Location:    /usr/local/lib/python3.6/site-packages/middlewared/client/client.py in call, line 421
Server time:    Fri, 4 May 2018 12:23:12 +0200
Traceback

Environment:

Software Version: FreeNAS-11.1-U4 (89e3d93bc)
Request Method: POST
Request URL: http://192.168.10.100/admin/network/lagginterface/add/

Traceback:
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner
  42.             response = get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _legacy_get_response
  249.             response = self._get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response
  178.             response = middleware_method(request, callback, callback_args, callback_kwargs)
File "./freenasUI/freeadmin/middleware.py" in process_view
  162.         return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
  23.                 return view_func(request, *args, **kwargs)
File "./freenasUI/freeadmin/options.py" in wrapper
  210.                 return self._admin.admin_view(view)(*args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/django/utils/decorators.py" in _wrapped_view
  149.                     response = view_func(request, *args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/django/views/decorators/cache.py" in _wrapped_view_func
  57.         response = view_func(request, *args, **kwargs)
File "./freenasUI/freeadmin/site.py" in inner
  142.             return view(request, *args, **kwargs)
File "./freenasUI/freeadmin/options.py" in add
  369.                         mf.done(request=request, events=events)
File "./freenasUI/network/forms.py" in done
  940.         notifier().start("network")
File "./freenasUI/middleware/notifier.py" in start
  202.             return c.call('service.start', what, {'onetime': onetime}, **kwargs)
File "./freenasUI/middleware/notifier.py" in start
  202.             return c.call('service.start', what, {'onetime': onetime}, **kwargs)
File "/usr/local/lib/python3.6/site-packages/middlewared/client/client.py" in call
  421.             raise ClientException(c.error, c.errno, c.trace, c.extra)

Exception Type: ClientException at /admin/network/lagginterface/add/
Exception Value: [Errno 17] File exists

Request information
GET

No GET data
POST
Variable    Value
__all__    ''
lagg_protocol    'lacp'
lagg_interfaces    'bxe1'
__form_id    'dialogForm_lagginterface'
FILES

No FILES data
COOKIES
Variable    Value
csrftoken    '********'
sessionid    'uyg2pls07tyrp4cybj9uo8uqrry3zup0'
fntreeSaveStateCookie    'root%2Croot%2F151%2Croot%2F147%2Croot%2F146'
META
Variable    Value

Associated revisions

Revision 2ab4b22a (diff)
Added by William Grzybowski 10 months ago

fix(middlewared): handle interface attach in middlewared

Ticket: #33294

Revision 49dc554c (diff)
Added by William Grzybowski 10 months ago

fix(middlewared): handle interface attach in middlewared

Ticket: #33294

Revision 90bc8796 (diff)
Added by William Grzybowski 10 months ago

fix(middlewared): handle interface attach in middlewared

Ticket: #33294

Revision 06040ee2 (diff)
Added by William Grzybowski 10 months ago

fix(middlewared): handle interface attach in middlewared

Ticket: #33294

History

#1 Updated by Dru Lavigne 12 months ago

  • Category changed from Build system to Middleware
  • Assignee changed from Release Council to William Grzybowski
  • Private changed from No to Yes
  • Seen in changed from 11.4 to 11.1-U4
  • Reason for Blocked set to Need additional information from Author

Thilo: please attach a debug (System -> Advanced -> Save Debug) to this ticket.

#2 Updated by William Grzybowski 12 months ago

  • Status changed from Unscreened to Blocked
  • Severity changed from Med High to Medium

#3 Updated by thilo nesnidal 11 months ago

  • File debug-freenas-20180516120618.tgz added

Uploaded debug information

#4 Updated by Dru Lavigne 11 months ago

  • Status changed from Blocked to Unscreened
  • Reason for Blocked deleted (Need additional information from Author)

#5 Updated by William Grzybowski 11 months ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Waiting for feedback

The error is very strange and i am not able to reproduce that locally.

Would you be open for a team viewer to debug this?

#6 Updated by William Grzybowski 11 months ago

Also,

can you try this manually to check if this works:

freenas# ifconfig lagg0 destroy              
freenas# ifconfig lagg0 create laggproto lacp up
freenas# ifconfig lagg0 laggport bge0            
freenas# ifconfig lagg0 laggport bge1
freenas# ifconfig lagg0

Thanks

#7 Updated by thilo nesnidal 11 months ago

Of course, we would be open for a team viewer session to debug this issue.
Can you suggest an appointment for the team viewer session in June between 12th to 15th ?

#8 Updated by William Grzybowski 11 months ago

June 14th in the morning (GMT-3) would work for me.

#9 Updated by thilo nesnidal 11 months ago

Unfortunately on June, 14th the client is not available.
Would you be so kind and propose a new date for the debugging session ?

#10 Updated by William Grzybowski 11 months ago

thilo nesnidal wrote:

Unfortunately on June, 14th the client is not available.
Would you be so kind and propose a new date for the debugging session ?

15th would work as well

#11 Updated by thilo nesnidal 11 months ago

According to the client, June, 14th in the morning would be possible now and he wants to go ahead as soon as possible.
So my apologies, can we still stick to June, 14th ?

#12 Updated by William Grzybowski 11 months ago

Yes, that is fine

#13 Updated by thilo nesnidal 11 months ago

Perfect.
which time would be best for you ?

#14 Updated by William Grzybowski 11 months ago

thilo nesnidal wrote:

Perfect.
which time would be best for you ?

Between 9AM-12AM my time (GMT-3)

#15 Updated by thilo nesnidal 11 months ago

Hi

I'm already onsite online. We could start any time.
how can we start over ?
skype session ?
phone call ?

Also I've got a teamviewer ID: 733 419 846
pw: f8hd71

#16 Updated by thilo nesnidal 11 months ago

root@freenas:~ # ifconfig lagg0 destroy
ifconfig: interface lagg0 does not exist

just to make sure that there is no lagg configured yet.

#17 Updated by William Grzybowski 11 months ago

  • Target version changed from Backlog to 11.2-RC2

Note: During the teamviewer session I discovered there is a race between middlewared and some event configuring lagg0. We were not able to figure out why lagg is not working.

#18 Updated by William Grzybowski 10 months ago

  • Status changed from Blocked to Not Started
  • Reason for Blocked deleted (Waiting for feedback)

#19 Updated by William Grzybowski 10 months ago

  • Status changed from Not Started to In Progress

https://github.com/freenas/freenas/pull/1368

Thilo, the above PR fixes the traceback.

Let us know if you have any luck with LAGG using Intel NICs.

#20 Updated by Dru Lavigne 10 months ago

  • File deleted (debug-freenas-20180516120618.tgz)

#21 Updated by Dru Lavigne 10 months ago

  • Subject changed from unable to establish LACP connection to Fix traceback when adding a LAGG
  • Status changed from In Progress to Ready for Testing
  • Target version changed from 11.2-RC2 to 11.2-BETA1
  • Private changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#22 Updated by Bonnie Follweiler 10 months ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Test Passed by Eric Turgeon

#23 Updated by Dru Lavigne 10 months ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF