Project

General

Profile

Bug #33300

Wait for system to fully boot before running alerts

Added by Joshua Sirrine over 1 year ago. Updated about 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Related projects 1 project

Description

I've seen this several times on systems running 11.1-U4. The Alert system gets a little agressive and finds faults during long startups and long pool imports.

I think the fix is to make the Alert system not come up until the system completes booting as well as waiting to check status of the system during a failover event. The last customer I worked with we did some failovers and reboots, and we'd get erroneous messages like lagg0 was down (it wasn't down and hadn't been for almost 5 minutes) and zpool status was unknown. In both cases, it generated emails to the customer, and in the case of the zpool status, it generated a support suite ticket automatically due to proactive support.

no alerts.png (17.1 KB) no alerts.png Rishabh Chauhan, 06/06/2018 08:16 AM
18178

Related issues

Has duplicate FreeNAS - Bug #31284: After Upgrade and reboots I get an email saying my pool was in an unknown state but, in the GUI, it's healthyClosed

Associated revisions

Revision 9c0fc385 (diff)
Added by Vladimir Vinogradenko over 1 year ago

fix(alert): Wait for system to fully boot before running alerts.

Ticket: #33300

History

#1 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 1 year ago

  • Assignee changed from Release Council to Vladimir Vinogradenko
  • Target version changed from 11.1-U5 to 11.2-RC2

#2 Updated by Dru Lavigne over 1 year ago

  • Project changed from TrueNAS to FreeNAS
  • Description updated (diff)
  • Category changed from Middleware to Middleware
  • Migration Needed deleted (No)
  • Hide from ChangeLog deleted (No)
  • Support Department Priority deleted (0)

#4 Updated by Dru Lavigne over 1 year ago

  • Description updated (diff)

#5 Updated by Vladimir Vinogradenko over 1 year ago

  • Status changed from Unscreened to Ready for Testing

#6 Updated by Vladimir Vinogradenko over 1 year ago

  • Has duplicate Bug #31284: After Upgrade and reboots I get an email saying my pool was in an unknown state but, in the GUI, it's healthy added

#8 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Wait for system to fully boot before running alerts. to Wait for system to fully boot before running alerts
  • Target version changed from 11.2-RC2 to 11.2-BETA1
  • Needs Merging changed from Yes to No

#9 Updated by Joshua Sirrine over 1 year ago

Just to ask the dumb question, is this tested to be working properly for TrueNAS HA systems? Is this also proper when doing failovers as well as cold bootups.

Thanks.

#10 Updated by Rishabh Chauhan about 1 year ago

18178

FreeNAS-11.2-MASTER-201806050447 doesn't show any alerts as soon the machine is booted
Refer screenshot

#11 Updated by Dru Lavigne about 1 year ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF