Project

General

Profile

Bug #33420

Read-only fields in Edit dataset and Edit zvol

Added by Dru Lavigne over 2 years ago. Updated over 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Vaibhav Chauhan
Category:
GUI (new)
Severity:
Med High
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

In the legacy UI these 3 fields are read-only when editing a dataset:

Dataset Name
Case Sensitivity
Record Size

In the new UI:

1. Dataset Name is read-only but there is no way to tell. The tooltip should change from "Mandatory; enter a unique name for the dataset." to "Dataset name (read-only)." (this similary applies to zvols)

2. Case Sensitivity is missing entirely in Edit Dataset. Since there isn't a column for it in the View Datasets screen, the user has no idea what the value is once the dataset is created. It should be added as read-only.

3. Record Size: is editable in Edit Dataset. Ot should be read-only and the tooltip updated to indicate it is read-only. I'm pretty sure ZFS does not allow this change after creation (or at the very least bad things will happen if it does)

4. on a related note, the UI needs to give some sort of visual that a field is read-only (tooltips help but don't guarantee that a user will hover over them)

Screen Shot 2018-05-15 at 2.09.53 PM.png (84.1 KB) Screen Shot 2018-05-15 at 2.09.53 PM.png Vaibhav Chauhan, 05/15/2018 11:10 AM
dataset.png (35.5 KB) dataset.png Dru Lavigne, 05/21/2018 08:41 AM
zvol.png (23.6 KB) zvol.png Dru Lavigne, 05/21/2018 08:41 AM
17475
17577
17580

Related issues

Related to FreeNAS - Bug #33435: 2 options missing in Add ZvolDone

History

#1 Updated by Dru Lavigne over 2 years ago

  • Description updated (diff)

#2 Updated by Eric Loewenthal over 2 years ago

recordsize can be safely set after creation, but will only affect new data.

#3 Updated by Dru Lavigne over 2 years ago

  • Subject changed from Read-only fields in Edit dataset to Read-only fields in Edit dataset and Edit zvol
  • Description updated (diff)

#4 Updated by Vaibhav Chauhan over 2 years ago

  • Assignee changed from Erin Clark to Vaibhav Chauhan

#5 Updated by Vaibhav Chauhan over 2 years ago

17475

Dru Lavigne wrote:

In the legacy UI these 3 fields are read-only when editing a dataset:

Dataset Name
Case Sensitivity
Record Size

In the new UI:

1. Dataset Name is read-only but there is no way to tell. The tooltip should change from "Mandatory; enter a unique name for the dataset." to "Dataset name (read-only)." (this similary applies to zvols)

2. Case Sensitivity is missing entirely in Edit Dataset. Since there isn't a column for it in the View Datasets screen, the user has no idea what the value is once the dataset is created. It should be added as read-only.

3. Record Size: is editable in Edit Dataset. Ot should be read-only and the tooltip updated to indicate it is read-only. I'm pretty sure ZFS does not allow this change after creation (or at the very least bad things will happen if it does)

edit mode for Record Size shows it to be editable, new UI functions the same way as well

4. on a related note, the UI needs to give some sort of visual that a field is read-only (tooltips help but don't guarantee that a user will hover over them)

#6 Updated by Vaibhav Chauhan over 2 years ago

so according to william, recordsize is editable therefore OLD and NEW UI is behaving as intended

and for the dataset part I am issuing https://github.com/freenas/webui/pull/738

#7 Updated by Vaibhav Chauhan over 2 years ago

  • Assignee changed from Vaibhav Chauhan to Erin Clark

#8 Updated by Erin Clark over 2 years ago

  • Status changed from Unscreened to Done
  • Assignee changed from Erin Clark to Vaibhav Chauhan

#9 Updated by Dru Lavigne over 2 years ago

17577
17580

For this one, the datasets look good, however the zvol one does not display the full zvol name or grey it out to indicate that it is read-only. See attached screenshots for a comparison. This is on FreeNAS-11.2-MASTER-201805210905.

#10 Updated by Vaibhav Chauhan over 2 years ago

  • Status changed from Unscreened to Done

with this ticket I was working with only dataset page. for zvols I already have #33435 where I can incorporate suggested changes, marking this as closed

#11 Updated by Dru Lavigne over 2 years ago

  • Related to Bug #33435: 2 options missing in Add Zvol added

#12 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.2-BETA1 to Master - FreeNAS Nightlies
  • Needs Merging changed from Yes to No

Also available in: Atom PDF