Project

General

Profile

Bug #33447

Can't create a clone

Added by Dru Lavigne over 2 years ago. Updated over 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Erin Clark
Category:
GUI (new)
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

See attached screenshot.

To reproduce, select a snapshot, click its Clone action, note that there is a default name pre-filled in for you, then click Save.

The default fails because it does not begin with name@. In this case, the snapshot name was correct () but the clone default was wrong (volume1-auto-20180511.1410-2h-clone).

example.png (12.1 KB) example.png Dru Lavigne, 05/11/2018 02:25 PM
example2.png (13.2 KB) example2.png Dru Lavigne, 05/11/2018 02:27 PM
example.png (12.4 KB) example.png Dru Lavigne, 05/21/2018 08:29 AM
screenshot-20180530-130919.jpg (9.53 KB) screenshot-20180530-130919.jpg Erin Clark, 05/30/2018 01:10 PM
screenshot-20180530-130906.jpg (12.9 KB) screenshot-20180530-130906.jpg Erin Clark, 05/30/2018 01:10 PM
17385
17388
17574
17938
17941

Associated revisions

Revision 3b764cd1 (diff)
Added by Erin Clark over 2 years ago

Make snapshot clone work for the root dataset like it does in the old UI Ticket: #33447

History

#1 Updated by Dru Lavigne over 2 years ago

17388

The second screenshot shows the reason why :-)

#2 Updated by Dru Lavigne over 2 years ago

  • Subject changed from Default clone name is incorrect so results in error to Can't create a clone due to incorrect regex

#3 Updated by Erin Clark over 2 years ago

  • Status changed from Unscreened to Screened

The regex is coming from the middleware side (I dont think you can make a dataset with an @ in it can you?). As for why it isn't creating a snapshot for you I am not quite sure but that error does not reproduce on my box.

#4 Updated by Erin Clark over 2 years ago

  • Status changed from Screened to Closed

This is the way the old UI works too, and I can't seem to get it to error out. AFAIK there is nothing to do here

#5 Updated by Dru Lavigne over 2 years ago

  • File example.png example.png added
  • Subject changed from Can't create a clone due to incorrect regex to Can't create a clone
  • Status changed from Closed to Unscreened
17574

I still can't create a clone on FreeNAS-11.2-MASTER-201805210905. Attached is the error.

To recreate: click on a snapshot in Storage -> Snapshots, click Clone (which gives a default clone name), and click Save.

#6 Updated by Erin Clark over 2 years ago

  • Status changed from Unscreened to Screened

#7 Updated by Erin Clark over 2 years ago

I'm still not quite sure how to reproduce this error, it just seems to work for me on my boxes

#8 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.2-BETA1 to 11.2-RC2
  • Severity changed from Med High to Medium

This needs more pinning down as it is not always reproducible.

#9 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.2-RC2 to 11.2-BETA1

William has confirmed that this happens when the snapshot is on the top level dataset and that the fix should be easy: make sure the clone starts with a `volumename/` instead of `volumename`.

#10 Updated by Erin Clark over 2 years ago

17938
17941

So I think I am confused as to how yours doesn't have the /, because mine does which is why it always just seems to work on mine. See the screenshots attached. I could possibly strip the path from the snapshot and add it in post but that would be changing the behavior.

#11 Updated by Erin Clark over 2 years ago

  • Assignee changed from Erin Clark to Vaibhav Chauhan

#12 Updated by Dru Lavigne over 2 years ago

  • Status changed from Screened to Done
  • Assignee changed from Vaibhav Chauhan to Erin Clark
  • Target version changed from 11.2-BETA1 to Master - FreeNAS Nightlies
  • Needs Merging changed from Yes to No

Also available in: Atom PDF