Project

General

Profile

Bug #33747

AFP Time Machine share broken by upgrade to FreeNAS 11.1

Added by Nick Tompson 11 months ago. Updated 9 months ago.

Status:
Closed
Priority:
No priority
Assignee:
John Hixson
Category:
Services
Target version:
Seen in:
Severity:
New
Reason for Closing:
Cannot Reproduce
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

ASRock C2750D4I in Node304 case
16 GB ECC Crucial CT2KIT102472BD160B
6x WD Green 3TB (WDIDLE'd) in RAIDZ2

ChangeLog Required:
No

Description

After upgrading from FreeNAS 9.10.2-U6 to 11.1-U4, I've experience instability in the AFP service. I've had Time Machine backups running for a few years very reliably. Since upgrading to from 9.10.2-U6 to 11.1-U4, TM backups work occasionally, but mostly I get a "TM share can't be found" error. When this happens, I find that the AFP TM share is not browsable from my Mac (which it normally is).

There is very little I can find in logs; FreeNAS shows the AFP service running fine. Restarting the AFP service sometimes gets TM going again, but not for long.

Only one [possibly] useful observation: in comparing start up logs between 9.10.2 and 11.1:

May 17 11:54:25 saturn netatalk[3530]: Netatalk AFP server starting
May 17 11:54:25 saturn netatalk[3530]: Registered with Zeroconf
May 17 11:54:25 saturn cnid_metad[3589]: CNID Server listening on localhost:4700
May 17 11:54:25 saturn afpd[3588]: Couldn't connect to system bus: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
May 17 11:54:25 saturn bridge0: Ethernet address: 02:d1:a7:3a:ff:00
May 17 11:54:25 saturn kernel: igb0: promiscuous mode enabled
May 17 11:54:25 saturn kernel: bridge0: link state changed to UP
May 17 11:54:25 saturn kernel: bridge0: link state changed to UP
May 17 11:54:28 saturn afpd[3588]: Netatalk AFP/TCP listening on 10.0.0.150:548
May 17 11:54:28 saturn afpd[3588]: No suitable network config for TCP socket
May 17 11:54:28 saturn afpd[3588]: Netatalk AFP/TCP listening on 10.0.0.150:548

All of this log activity occurs in both releases, with the exception of the "couldn't connect to system bus..." entry - this only occurs in 11.1.

Upon rebooting with 9.10.2, Time Machine works just fine again. I've uploaded my AFP / TM config as set in 9.10.2. I haven't attempted to change any configuration in 11.1

AFP service config.png (245 KB) AFP service config.png Nick Tompson, 05/19/2018 02:38 AM
AFP TM share config - 1.png (180 KB) AFP TM share config - 1.png Nick Tompson, 05/19/2018 02:38 AM
AFP TM share config - 2.png (110 KB) AFP TM share config - 2.png Nick Tompson, 05/19/2018 02:38 AM
TM dataset permissions.png (145 KB) TM dataset permissions.png Nick Tompson, 05/19/2018 02:38 AM
TM dataset config.png (187 KB) TM dataset config.png Nick Tompson, 05/19/2018 02:38 AM
17538
17541
17544
17547
17550

History

#1 Updated by Dru Lavigne 11 months ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Nick: please attach a debug (System -> Advanced -> Save Debug) to this ticket.

#2 Updated by Nick Tompson 11 months ago

  • File debug-saturn-20180522070948.tar added

Sorry for the delay. Please see attached a debug dump, taken a few days ago. The dump is from shortly after a boot into FN11.1 (previous boot was FN9.10.2).

#3 Updated by Dru Lavigne 11 months ago

  • Assignee changed from Release Council to Timur Bakeyev
  • Reason for Blocked deleted (Need additional information from Author)

#4 Updated by John Hixson 10 months ago

  • Assignee changed from Timur Bakeyev to John Hixson

#5 Updated by John Hixson 10 months ago

  • Status changed from Unscreened to Screened

#6 Updated by Nick Tompson 9 months ago

Just wondering whether there is an update? On my side, I find that AFP fails to start whenever I reboot. Restarting the AFP service fixes it. I generally find that the AFP service remains stable for a few days. Usually I need to restart the AFP service when I notice that the time machine backups have stopped.

#7 Updated by John Hixson 9 months ago

  • Status changed from Screened to Blocked
  • Reason for Blocked set to Waiting for feedback

Nick Tompson wrote:

Just wondering whether there is an update? On my side, I find that AFP fails to start whenever I reboot. Restarting the AFP service fixes it. I generally find that the AFP service remains stable for a few days. Usually I need to restart the AFP service when I notice that the time machine backups have stopped.

Would you be willing to update to the beta? As for what you pointed out, it very well may be relevant. I can confirm that on 11.1-U4, the ordering of the startup scripts is wrong, so netatalk is beginning before dbus is, which is definitely causing problems. This has since been fixed and if you can update to 11.2BETA and confirm this, that would be great.

#8 Updated by John Hixson 9 months ago

  • Category changed from OS to Services

#9 Updated by John Hixson 9 months ago

  • Status changed from Blocked to Closed
  • Reason for Closing set to Cannot Reproduce
  • Reason for Blocked deleted (Waiting for feedback)

I'm closing this since I believe we've fixed this in 11.2. If still an issue please open a new ticket and provide the necessary information.

#10 Updated by Dru Lavigne 9 months ago

  • File deleted (debug-saturn-20180522070948.tar)

#11 Updated by Dru Lavigne 9 months ago

  • Target version changed from Backlog to N/A
  • Private changed from Yes to No

Also available in: Atom PDF