Project

General

Profile

Bug #34522

Allow reset of SED password in UI

Added by Jake Baynham 11 months ago. Updated 10 months ago.

Status:
Done
Priority:
No priority
Assignee:
Waqar Ahmed
Category:
Middleware
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Can't clear/reset SED password in GUI.

1. Set SED password
2. Do not initialize SED or non SED disk
3. Attempt to blank out password
4. Bulleted dots remain in GUI - Password will not blank out.

Annotation.png (44.8 KB) Annotation.png Jake Baynham, 06/04/2018 11:06 AM
18118

Associated revisions

Revision 284df072 (diff)
Added by Waqar Ahmed 11 months ago

Functionality to reset SED password in GUI added
Ticket: #34522

Revision 67bd1041 (diff)
Added by Waqar Ahmed 11 months ago

Functionality to reset SED password in GUI added
Ticket: #34522

Revision 2b7013c0 (diff)
Added by Waqar Ahmed 11 months ago

Functionality to reset SED password in GUI added
Ticket: #34522

Revision a0889539 (diff)
Added by Dru Lavigne 10 months ago

Doc ability to reset SED password.
Ticket: #34522

Revision 7d644171 (diff)
Added by Dru Lavigne 10 months ago

Doc ability to reset SED password.
Ticket: #34522

Revision 016af4ef (diff)
Added by Waqar Ahmed 10 months ago

Functionality to reset SED passwords added
Ticket: #34522

Revision 405ac2bb (diff)
Added by Waqar Ahmed 10 months ago

Functionality to reset SED Password added
Ticket: #34522

Revision fd71a4fd (diff)
Added by Waqar Ahmed 10 months ago

Functionality to reset SED Password added
Ticket: #34522

Revision 655d2f29 (diff)
Added by Waqar Ahmed 10 months ago

Functionality to reset SED Password added
Ticket: #34522

Revision 3aa7a2dc (diff)
Added by Waqar Ahmed 10 months ago

Functionality to reset SED Password added
Ticket: #34522

History

#1 Updated by Jake Baynham 11 months ago

  • File debug-FREENAS-20180604180619.txz added
  • Private changed from No to Yes

#2 Updated by Jake Baynham 11 months ago

18118

#3 Updated by Dru Lavigne 11 months ago

  • Category changed from Hardware to Middleware
  • Assignee changed from Release Council to William Grzybowski

#4 Updated by William Grzybowski 11 months ago

  • Assignee changed from William Grzybowski to Waqar Ahmed
  • Target version changed from Backlog to 11.2-RC2
  • Severity changed from New to Medium
  • Needs Merging changed from Yes to No

#5 Updated by Waqar Ahmed 11 months ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Waiting for feedback

Jake could you please confirm if I followed you correctly. So the issue is that you are unable to reset the password to null once it has been set ?
And is there anything else that I am missing. Looking forward to hearing from you. Cheers

#6 Updated by Jake Baynham 11 months ago

Waqar Ahmed wrote:

Jake could you please confirm if I followed you correctly. So the issue is that you are unable to reset the password to null once it has been set ?
And is there anything else that I am missing. Looking forward to hearing from you. Cheers

That is correct. The dots stay in the UI and don’t provide any indication that the password is blank or still applied (I assume still applied).

#7 Updated by Waqar Ahmed 11 months ago

  • Status changed from Blocked to In Progress
  • Reason for Blocked deleted (Waiting for feedback)

#8 Updated by Waqar Ahmed 11 months ago

  • Status changed from In Progress to Ready for Testing

#9 Updated by Dru Lavigne 11 months ago

  • File deleted (debug-FREENAS-20180604180619.txz)

#10 Updated by Dru Lavigne 11 months ago

  • Subject changed from Can't reset SED password in GUI to Allow reset of SED password in UI
  • Target version changed from 11.2-RC2 to 11.2-BETA1

#11 Updated by Dru Lavigne 11 months ago

  • Private changed from Yes to No

#12 Updated by Bonnie Follweiler 10 months ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Test Passed in FreeNAS-11.2-INTERNAL4

#13 Updated by Dru Lavigne 10 months ago

  • Target version changed from 11.2-BETA1 to 11.1-U6

#15 Updated by Dru Lavigne 10 months ago

  • Status changed from Passed Testing to Done
  • Needs Doc changed from Yes to No

Also available in: Atom PDF