Project

General

Profile

Bug #3455

Internet Explorer 10/11 compat issues with FreeNAS

Added by Anonymous almost 8 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

The following report was submitted to iXsystems support from Microsoft:

Hello - I am a Program Manager with the Ecosystem Engineering team at Microsoft and our team works with 3rd party websites regarding the latest in Internet Explorer compatibility. I am writing to notify you of a compatibility issue with freenas on Internet Explorer.

Based upon IE testing, the following issue has been found:

Reference #: 542360
Description of the Problem: Freenas Web Administration interface issue
Steps to Reproduce:

1. Navigate to a local Freenas (freenas.org) server (Issue has been reproduced on 8.3.1 and 9.1.1) using Internet Explorer 11 or Internet Explorer 10

2. Observe the navigation control required to administer the server over the web does not work in IE11 or IE10

Expected Result: Users should see a proper tree view control for all the options on the server
Actual Result: Users cannot see the tree view control. Please see screenshot attached.

Developer Notes: It appears that Freenas is doing browser detection and may not be properly recognizing IE11 and IE10. Here is the new IE11 user-agent string.

Mozilla/5.0 (Windows NT 6.3; Trident/7.0; rv:11.0) like Gecko

If you compare the new user-agent string to the one reported by earlier versions of IE

  • The compatible ("compatible") and browser ("MSIE") tokens have been removed.
  • The "like Gecko" token has been added (for consistency with other browsers).
  • The version of the browser is now reported by a new revision ("rv") token.

These changes help prevent IE11 from being (incorrectly) identified as an earlier version.

Also, if Freenas is using ASP.NET, a patch might be necessary for the framework to correctly recognize the IE11 and IE10 User Agent String.

Here is the entire list of the ASP.NET patches. Please choose the appropriate link for your specific version and OS to update with the security patch.

KB

Product-platform

2836939<http://support.microsoft.com/kb/2836939>

NDP 4 - Win7SP1/Win2K3SP2/Win2K8R2SP1/Win2K8SP2/VistaSP2/WinXPSP3

2836940<http://support.microsoft.com/kb/2836940>

NDP 3.5 SP1 - Win2K3SP2/Win2K8SP2/VistaSP2/WinXPSP3

2836941<http://support.microsoft.com/kb/2836941>

NDP 2.0 SP2 - Win2K3SP2/WinXPSP3

2836942<http://support.microsoft.com/kb/2836942>

NDP 3.5 SP1 - Win7SP1/Win2K8R2SP1

2836943<http://support.microsoft.com/kb/2836943>

NDP 2.0 SP2 - Win7SP1/Win2K8R2SP1

2836945<http://support.microsoft.com/kb/2836945>

NDP 2.0 SP2 - Win2K8SP2/VistaSP2

2836946<http://support.microsoft.com/kb/2836946>

NDP 2.0 SP2 - Win8RTM/WinRTRTM/Win2K12RTM

2836947<http://support.microsoft.com/kb/2836947>

NDP 3.5 SP1 - Win8RTM/WinRTRTM/Win2K12RTM

If you haven't heard already, Windows 8.1 is here<http://blogs.windows.com/windows/b/bloggingwindows/archive/2013/10/17/windows-8-1-now-available.aspx> and available to download! Additionally, consumers on Windows 8 can now download the free update through the Windows Store.

Call to Action:

1. Download Windows 8.1 which includes Internet Explorer 11 through the Windows Store, learn more online at http://windows.microsoft.com/buy or download IE11 for Windows 7<http://blogs.msdn.com/b/ie/archive/2013/11/07/ie11-for-windows-7-globally-available-for-consumers-and-businesses.aspx>

2. Learn more about Internet Explorer 11, http://msdn.microsoft.com/library/ie/bg182636(v=vs.85) or http://msdn.microsoft.com/library/ie/dn384059(vs.85)

3. Test your site using Modern.ie<http://www.modern.ie/en-us> - Microsoft's new tool that will help identify and resolve common compatibility issues. A virtual machine option is available to assist in testing sites with IE11.

4. While testing, make sure your site isn't running in Compatibility View<http://msdn.microsoft.com/en-us/library/dd567845(v=vs.85).aspx#removal> or else you may not see the problem

Please let me know if you have an estimated timeframe to address this issue, and if our team can further assist in this process. Thanks!

KELLY YOKOTE
Microsoft PC Ecosystem Engineering Team
PROGRAM MANAGER | IE Compatibility

(Email and phone number withheld from public bugbase)

Actual-IE-542360.PNG (27.2 KB) Actual-IE-542360.PNG Anonymous, 11/19/2013 12:36 AM
Win7Explorer11.JPG (48 KB) Win7Explorer11.JPG gear head, 01/31/2014 06:15 AM
123
383

Related issues

Has duplicate FreeNAS - Bug #3737: script or certificat error using windows 8.1 with IE 11.1 Closed: Duplicate2013-12-18

Associated revisions

Revision 52b0be23 (diff)
Added by William Grzybowski over 7 years ago

Fix tree menu for IE10/11 Ticket: #3455

History

#1 Updated by Xin Li almost 8 years ago

  • Status changed from Unscreened to Screened
  • Assignee set to William Grzybowski

#2 Updated by Chen Xing over 7 years ago

I believe that the issue originates from the anonymous function in "freeadmin.js" having two arguments that are both called "ForestStoreModel". Renaming either of them seems to fix the problem. The commit history suggests that "treeModel" is intended to be a "freeadmin.tree.ForestStoreModel".

#3 Updated by Jordan Hubbard over 7 years ago

  • Target version set to 74

Do you have access to a copy of IE 10/11, William? Can we arrange an RDP instance for you if not? windows1 has got the latest IE on it, and I can verify that various UI elements don't work on it (I noticed it when I attempted to do a Firmware update). A lot of folks seem to be complaining about this. Also, see comments above by Chen Xing - looks like he may have a solution!

#4 Updated by William Grzybowski over 7 years ago

  • Status changed from Screened to Resolved

#5 Updated by gear head over 7 years ago

383

it works properly with internet explorer 11 on windows 8.1. However, internet explorer 11 on windows 7 produces jumbled icons. please see attached screen shot.

#6 Updated by Jordan Hubbard over 7 years ago

  • Status changed from Resolved to Closed

#7 Updated by Jordan Hubbard over 6 years ago

  • Target version changed from 74 to 9.2.1-RELEASE

Also available in: Atom PDF