Project

General

Profile

Feature #34636

Reload iSCSI when zvol size changes on legacy UI

Added by Sam Fourman 10 months ago. Updated 10 months ago.

Status:
Done
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Estimated time:
Severity:
Low Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

TrueNAS customer would like to emulate dynamic resizing of ZVOL backed iSCSI
Expanding a ZVOL does not automatically cause iSCSI to see the new Size.

Using /etc/rc.d/ctld reload does not disrupt other iSCSI connections

Currently there is no way to use ctld reload from the webUI all you can do is restart the entire service.


Related issues

Related to FreeNAS - Bug #36668: Fix validation of extent size in new UIDone
Related to FreeNAS - Bug #35551: Fix creating zvol with volblocksizeDone
Copied to FreeNAS - Feature #76350: Reload iSCSI when zvol size changes on legacy UIDone

Associated revisions

Revision e220bbd7 (diff)
Added by William Grzybowski 10 months ago

feat(mw|gui): reload iscsi when zvol size changes

Ticket: #34636

Revision 667f0e15 (diff)
Added by William Grzybowski 10 months ago

feat(mw|gui): reload iscsi when zvol size changes

Ticket: #34636

Revision 844f24a9 (diff)
Added by William Grzybowski 10 months ago

feat(mw|gui): reload iscsi when zvol size changes

Ticket: #34636

Revision 4290e325 (diff)
Added by William Grzybowski about 2 months ago

feat(mw|gui): reload iscsi when zvol size changes

Ticket: #34636

History

#2 Updated by Dru Lavigne 10 months ago

  • Category set to Middleware

#3 Updated by William Grzybowski 10 months ago

  • Status changed from Unscreened to Not Started
  • Severity changed from New to Low Medium
  • Needs Merging changed from Yes to No

#4 Updated by William Grzybowski 10 months ago

  • Status changed from Not Started to Ready for Testing
  • Target version changed from 11.2-RC2 to 11.2-BETA1
  • Needs Doc changed from Yes to No

#5 Updated by Dru Lavigne 10 months ago

  • Subject changed from New middleware plumming for ctld reload to Reload iSCSI when zvol size changes

#6 Updated by Paul Walker 10 months ago

Testing on this is blocked by Bug #35551

#7 Updated by Timothy Moore II 10 months ago

Testing on FreeNAS mini installed with INTERNAL14:

Configured iSCSI sharing with a zvol in the new UI. Errors: could not start iSCSI service and Extent size is being misreported in /etc/ctl.conf

Opening tickets about these problems and linking them to this issue.

#8 Updated by Timothy Moore II 10 months ago

  • Status changed from Ready for Testing to Blocked

#9 Updated by Timothy Moore II 10 months ago

  • Related to Bug #36668: Fix validation of extent size in new UI added

#10 Updated by Dru Lavigne 10 months ago

  • Related to Bug #35551: Fix creating zvol with volblocksize added

#11 Updated by Dru Lavigne 10 months ago

  • Status changed from Blocked to Failed Testing

#12 Updated by William Grzybowski 10 months ago

  • Subject changed from Reload iSCSI when zvol size changes to Reload iSCSI when zvol size changes on legacy UI
  • Status changed from Failed Testing to Ready for Testing

Timothy Moore II wrote:

Testing on FreeNAS mini installed with INTERNAL14:

Configured iSCSI sharing with a zvol in the new UI. Errors: could not start iSCSI service and Extent size is being misreported in /etc/ctl.conf

Opening tickets about these problems and linking them to this issue.

This ticket is for legacy UI (it refers to TrueNAS which is what they use). Can you please verify on legacy UI?

#13 Updated by Timothy Moore II 10 months ago

  • Status changed from Ready for Testing to Failed Testing

Sorry about missing that - retesting with FreeNAS Mini installed with INTERNAL14, legacy UI only:

Manually configure iSCSI settings and set up an zvol device extent. Connect to the shared zvol extent with my local box and use camcontrol to check the size of the connected zvol. Everything looked ok, so I moved back to the FreeNAS Mini and resized the zvol from 500 GiB to 600 GiB. Back on the local box, I rechecked the size again and tried over the course of several minutes - no update to the maximum size of the connected zvol. I used service ctld onereload on the Mini and checked again on the local box - the connected zvol size was updated. This seems to confirm the reported behavior is still what is happening on the box.

#14 Updated by William Grzybowski 10 months ago

Timothy Moore II wrote:

Sorry about missing that - retesting with FreeNAS Mini installed with INTERNAL14, legacy UI only:

Manually configure iSCSI settings and set up an zvol device extent. Connect to the shared zvol extent with my local box and use camcontrol to check the size of the connected zvol. Everything looked ok, so I moved back to the FreeNAS Mini and resized the zvol from 500 GiB to 600 GiB. Back on the local box, I rechecked the size again and tried over the course of several minutes - no update to the maximum size of the connected zvol. I used service ctld onereload on the Mini and checked again on the local box - the connected zvol size was updated. This seems to confirm the reported behavior is still what is happening on the box.

I dont seem to be able to reproduce this.
Did you create the extent on new UI?

#15 Updated by William Grzybowski 10 months ago

Also, do we understand that you have to reconnect the iscsi client?

#16 Updated by William Grzybowski 10 months ago

One more thing, is iSCSI service already started with "start on boot" checked?

#17 Updated by Timothy Moore II 10 months ago

So for the testing procedure, I wiped everything I had done on the new GUI, disabled the iSCSI service, then switched to the legacy UI and started completely fresh. I built a new extent using the legacy UI only. I enabled the iSCSI service after finishing all the configuration details, but did not have "start on boot" set. I did not reset the iSCSI connection from local client; my read of the original issue led me to think that it would dynamically update. I'll wipe this mini, install INTERNAL16, and try the test again.

#18 Updated by William Grzybowski 10 months ago

Timothy Moore II wrote:

So for the testing procedure, I wiped everything I had done on the new GUI, disabled the iSCSI service, then switched to the legacy UI and started completely fresh. I built a new extent using the legacy UI only. I enabled the iSCSI service after finishing all the configuration details, but did not have "start on boot" set. I did not reset the iSCSI connection from local client; my read of the original issue led me to think that it would dynamically update. I'll wipe this mini, install INTERNAL16, and try the test again.

Please make sure "start on boot" is checked, it is an assumption made in the UI to properly reload the service.
Making it reload with start on boot unchecked can be considered a bug affecting many other services as well, which maybe grant a different bug report (if there isnt one already).

#19 Updated by Dru Lavigne 10 months ago

  • Status changed from Failed Testing to Ready for Testing

#20 Updated by Timothy Moore II 10 months ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Thanks for the help - looks like it is working as expected. Here's my full step by step for the retest:

  • Reinstalled INTERNAL16
  • Switched to legacy UI and log in.
  • Closed initial wizard
  • Storage/Volumes/Volume Manager: create volume “test-34363” with one disk.
  • Add zvol “resize” to “test-34363”.
  • Sharing/Block (iSCSI)/Target Global Configuration: Set ISNS Servers and Pool Available Space Threshold.
  • Add portal with all default settings.
  • Add initiator with all default settings.
  • Add Target “testing-34636”.
  • Add Extent “testextent” with zvol “resize”.
  • Add Target/Extent with the created Target “testing-34636” and Extent “testextent”.
  • Services/iSCSI: set “Start on boot” and click “Start Now”.
  • Move to local system CLI:
    su
    service iscsid start
    iscsictl -A -p 10.231.1.3 -t iqn.2005-10.org.freenas.ctl:testing-34636
    camcontrol readcap /dev/da0
    Last Block: 209715199, Block Length: 512 bytes
    
  • Move back to legacy FreeNAS UI.
  • Edit zvol “resize” and set size to 200 GiB.
  • Move to local system CLI:
    camcontrol readcap /dev/da0
    (pass3:iscsi1:0:0:0): READ CAPACITY(10). CDB: 25 00 00 00 00 00 00 00 00 00
    (pass3:iscsi1:0:0:0): CAM status: SCSI Status Error
    (pass3:iscsi1:0:0:0): SCSI status: Check Condition
    (pass3:iscsi1:0:0:0): SCSI sense: UNIT ATTENTION asc:2a,9 (Capacity data has changed)
    service iscsid restart
    Stopping iscsid … [ ok ]
    Starting iscsid … [ ok ]
    camcontrol readcap /dev/da0
    Last Block: 419430399, Block Length: 512 bytes
    

#21 Updated by Dru Lavigne 10 months ago

  • Status changed from Passed Testing to Done

#22 Updated by Bug Clerk about 2 months ago

  • Copied to Feature #76350: Reload iSCSI when zvol size changes on legacy UI added

Also available in: Atom PDF