Project

General

Profile

Bug #34681

Glitches observed in new UI Shell as listed in the description

Added by Rishabh Chauhan over 3 years ago. Updated about 3 years ago.

Status:
Done
Priority:
No priority
Assignee:
Lola Yang
Category:
GUI (new)
Severity:
Med High
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

observed in FreeNAS-11.2-MASTER-201806080448
1. Refer image:shellnotnormal
- The shell interestingly after a certain number of characters starts re-writing the same line and that too from the very edge over-writing the directory# and then rest of the line.

2. Refer image:shellblank
- When I tried to erase the text, it erased the whole line, including the directory# leaving the shell with a blank black background

3. Refer image:shellbug
- after investigating this a little more, I found that the shell do that after exactly 80 characters are utilized (including directory#)
- also, the shell can print beyond 80 characters as you can see in the image.
- even if the shell has limitation of 80 characters for a reason, the rest of the shell screen is misleading as it gives an impression that you can type in a long command because of the width of black background

shellbug.png (57.7 KB) shellbug.png Rishabh Chauhan, 06/08/2018 08:02 AM
shellnotnormal.png (9.58 KB) shellnotnormal.png Rishabh Chauhan, 06/08/2018 08:07 AM
shellblank.png (3.87 KB) shellblank.png Rishabh Chauhan, 06/08/2018 08:09 AM
18307
18310
18313

History

#1 Updated by Rishabh Chauhan over 3 years ago

Rishabh Chauhan wrote:
observed in FreeNAS-11.2-MASTER-201806080448

1. Refer image:shellnotnormal
- The shell interestingly after a certain number of characters starts re-writing the same line and that too from the very edge over-writing the directory# and then rest of the line.

2. Refer image:shellblank
- When I tried to erase the text, it erased the whole line, including the directory# leaving the shell with a blank black background

3. Refer image:shellbug
- after investigating this a little more, I found that the shell do that after exactly 80 characters are utilized (including directory#)
- also, the shell can print beyond 80 characters as you can see in the image.
- even if the shell has limitation of 80 characters for a reason, the rest of the shell screen is misleading as it gives an impression that you can type in a long command because of the width of black background

#2 Updated by Dru Lavigne over 3 years ago

  • Assignee changed from Release Council to Anonymous
  • Target version changed from Backlog to 11.2-BETA1

#3 Updated by Anonymous over 3 years ago

  • Status changed from Unscreened to Screened

#4 Updated by Anonymous over 3 years ago

  • Assignee changed from Anonymous to Lola Yang

#5 Updated by Lola Yang over 3 years ago

  • Status changed from Screened to In Progress
  • Assignee changed from Lola Yang to Anonymous

This issue is caused by resize and the setting of cols/rows. i am comment out those for now. we will figure out the resize thing on 11.3 (confirmed with Erin)

Please review: https://github.com/freenas/webui/pull/892

#6 Updated by Dru Lavigne over 3 years ago

  • Status changed from In Progress to Done
  • Assignee changed from Anonymous to Lola Yang
  • Target version changed from 11.2-BETA1 to Master - FreeNAS Nightlies
  • Needs Merging changed from Yes to No

Also available in: Atom PDF