Project

General

Profile

Bug #34738

FreeNAS Nightly: NFS Share page: Authorized Networks: Doesn't allow IPv6 networks anymore

Added by Larry Rosenman over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Release Council
Category:
OS
Target version:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I've had my IPv6 network (2600:1700:210:b180::/60) in the authorized network list, recently I started to get permissions issues for root mounts.

Removing both the IPv4 and IPv6 networks fixes the permissions issue.

The error is "expected 4 octets".

This is NOT cool in 2018.


Related issues

Is duplicate of FreeNAS - Bug #34741: Support IPv6 networks for NFS shares Done

History

#1 Updated by Larry Rosenman over 2 years ago

This occurs on BOTH legacy and new UI.

#2 Updated by Larry Rosenman over 2 years ago

18337

Note the bottom of the screen

#3 Updated by Larry Rosenman over 2 years ago

OS Version:
FreeNAS-11.2-MASTER-201806060445

(Build Date: Jun 6, 2018 7:38)

#4 Updated by Dru Lavigne over 2 years ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Larry: please attach a debug (created after reproducing) so we can determine if it is a middleware or UI issue.

#5 Updated by Larry Rosenman over 2 years ago

#6 Updated by Dru Lavigne over 2 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Private changed from Yes to No
  • Reason for Closing set to Duplicate Issue
  • Reason for Blocked deleted (Need additional information from Author)

#7 Updated by Dru Lavigne over 2 years ago

  • Is duplicate of Bug #34741: Support IPv6 networks for NFS shares added

Also available in: Atom PDF