Project

General

Profile

Bug #34768

Add note to new UI version of Guide to unset Zoom Text Only

Added by Michael Reynolds about 1 year ago. Updated 12 months ago.

Status:
Done
Priority:
No priority
Assignee:
Aaron St. John
Category:
Documentation
Target version:
Severity:
Low
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When text size is at 100% everything in the top blue menu bar and items like the yellow Add button (FAB button?) look great.
See Alignmentat100percent-2018-06-11.png
As text size is reduced, everything falls out of alignment as things shrink. The menu buttons seem anchored to a point instead of being centered, and the + in the yellow Add button looks odd.
See AlignmentOffat50percent-2018-06-11.png

I shrunk Firefox to 50% to make this issue easier to see.

Alignmentat100percent-2018-06-11.png (121 KB) Alignmentat100percent-2018-06-11.png Michael Reynolds, 06/11/2018 09:27 AM
AlignmentOffat50percent-2018-06-11.png (187 KB) AlignmentOffat50percent-2018-06-11.png Michael Reynolds, 06/11/2018 09:29 AM
JailsInStorage-2018-06-11.png (145 KB) JailsInStorage-2018-06-11.png Michael Reynolds, 06/11/2018 10:03 AM
Screenshot from 2018-06-20 09-37-00.png (1.15 MB) Screenshot from 2018-06-20 09-37-00.png Firefox zoom options Dennis Mullen, 06/20/2018 06:40 AM
2.mkv (796 KB) 2.mkv Google calendar responds like our UI Dennis Mullen, 06/20/2018 06:41 AM
3.mkv (927 KB) 3.mkv Zoom looks good if you zoom the whole structure Dennis Mullen, 06/20/2018 06:41 AM
18355
18358
18364
19015

History

#1 Updated by Michael Reynolds about 1 year ago

PS I used the Jails section in my screenshots, but have confirmed this happens in every section.

#2 Updated by Michael Reynolds about 1 year ago

18364

I found this also applies to text in tables.
See JailsInStorage-2018-06-11.png

The text gets smaller but the table itself does not.
The text seems to be 'anchored' to the top left of a cell.

1 of the issues here is I shrunk the text size to fit more info on the screen, but I don't get more info, I just get smaller text.

I have not tried this in other browsers to see if this is specific to firefox. I suspect it is not.

#3 Updated by Erin Clark about 1 year ago

  • Assignee changed from Erin Clark to Dennis Mullen

#4 Updated by Dennis Mullen about 1 year ago

  • Status changed from Unscreened to Screened
  • Severity changed from New to Low

#5 Updated by Dennis Mullen about 1 year ago

19015

I think this one works as it should. If you choose to zoom text only (see screen shot from Firefox settings) it definitely causes these alignment problems, even on Google's material pages (see video). But if you zoom the whole view, the whole UI scales nicely (see the other video).

#6 Updated by Michael Reynolds about 1 year ago

This is closeable
Unsetting zoom text only in Firefox does resolve a lot of alignment/size issues

#7 Updated by Michael Reynolds about 1 year ago

  • Assignee changed from Dennis Mullen to Michael Reynolds
  • Target version changed from Backlog to 11.2-BETA2

Reassigning to myself to update the Logging in section of getting started section of the docs
Advise to unset View -> Zoom -> Zoom Text Only
to fix some display issues in the angulargui

#8 Updated by Dru Lavigne about 1 year ago

  • Subject changed from Buttons do not shrink gracefully when reducing text size to Add note to Guide to unset Zoom Text Only
  • Category changed from GUI (new) to Documentation

#9 Updated by Dru Lavigne 12 months ago

  • Status changed from Screened to Not Started

#10 Updated by Aaron St. John 12 months ago

Build: FreeNAS-11.2-MASTER-201807230852

Updated the docs with a note about that setting and zooming.

PR: https://github.com/freenas/freenas-docs/pull/212

#11 Updated by Aaron St. John 12 months ago

  • Status changed from Not Started to In Progress

#12 Updated by Dru Lavigne 12 months ago

  • Subject changed from Add note to Guide to unset Zoom Text Only to Add note to new UI version of Guide to unset Zoom Text Only
  • Status changed from In Progress to Done
  • Assignee changed from Michael Reynolds to Aaron St. John
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

Also available in: Atom PDF