Project

General

Profile

Bug #34825

Add UI error message for VM memory usage

Added by Timothy Moore II over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Severity:
Med High
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

https://redmine.ixsystems.com/issues/26480 is resolved with error messages added to /var/log/middlewared. In the UI, all that is seen is the VM not starting properly. Could the error message be passed to the UI so the user can see the error message about VM memory usage?


Related issues

Related to FreeNAS - Bug #26480: Add a seatbelt for the amount of memory on the host machine available for VM guestsDone
Related to FreeNAS - Bug #30127: VM start from GUI not workingClosed
Is duplicate of FreeNAS - Bug #26434: Add descriptive error to API when VM fails to startDone

Associated revisions

Revision 2c712e4e (diff)
Added by Marcelo Araujo over 1 year ago

- If we can't reserve memory from ZFS ARC for a guest VM, we need to let the upper layer knows about it. Ticket: #34825

Revision b87fe631 (diff)
Added by Marcelo Araujo over 1 year ago

- If we can't reserve memory from ZFS ARC for a guest VM, (#1403) * - If we can't reserve memory from ZFS ARC for a guest VM, we need to let the upper layer knows about it. Ticket: #34825 * - Use errno modules instead of a string "ENOMEM". * Address the reviewer request. * Fix a misspelling. * - Revert hashes: 81db0b2b82bb8ec2088447a20c55964008d92282 and 7b55b0741be8806532f62ffd4e738dab3efebd9f. There are some logics that need to be reworked to be able to address it in the way how the reviewer wants, or otherwise there is a risk where users can try to launch the same VM more than once.

History

#1 Updated by Timothy Moore II over 1 year ago

  • Related to Bug #26480: Add a seatbelt for the amount of memory on the host machine available for VM guests added

#2 Updated by Erin Clark over 1 year ago

  • Assignee changed from Erin Clark to Vaibhav Chauhan
  • Target version changed from Backlog to 11.2-RC2
  • Severity changed from New to Med High
  • Needs Merging changed from Yes to No

#4 Updated by Vaibhav Chauhan over 1 year ago

  • Assignee changed from Vaibhav Chauhan to Marcelo Araujo

in order to work what is desired I will be needing middleware to throw an appropriate error, which it does not when I use vm.start method.

#5 Updated by Marcelo Araujo over 1 year ago

  • Status changed from Unscreened to Screened

#6 Updated by Marcelo Araujo over 1 year ago

  • Status changed from Screened to In Progress

#7 Updated by Marcelo Araujo over 1 year ago

  • Related to Bug #30127: VM start from GUI not working added

#8 Updated by Marcelo Araujo over 1 year ago

  • Assignee changed from Marcelo Araujo to William Grzybowski

Please, remember to merge it till we have a better solution in place.
Thanks!

#9 Updated by William Grzybowski over 1 year ago

  • Category changed from GUI (new) to Middleware
  • Status changed from In Progress to Screened

#10 Updated by William Grzybowski over 1 year ago

  • Status changed from Screened to Closed
  • Reason for Closing set to Duplicate Issue

This will be handled as part of #26434

#11 Updated by William Grzybowski over 1 year ago

  • Is duplicate of Bug #26434: Add descriptive error to API when VM fails to start added

#12 Updated by Dru Lavigne over 1 year ago

  • Target version changed from 11.2-RC2 to N/A

Also available in: Atom PDF