Project

General

Profile

Bug #34969

Properly handle dataset recordsize of 1M

Added by Caleb St. John over 2 years ago. Updated about 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
TrueNAS - TrueNAS 11.1-U5
Severity:
Low
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Related projects 1 project

Description

on 11.1-U5, changing the recordsize of a dataset (from the GUI) doesn't reflect the change that has been made.

To reproduce:
1. create dataset
2. during creation, click on advanced and set recordsize to 1024k
3. double-click said dataset
4. look at the recordsize and it will show (inherited)

The webUI should show 1024K instead of inherited.

This does, however, change the recordsize at the OS level.

root@eye-02:~ # zfs get recordsize cargo-enc
root@eye-02:~ # zfs get recordsize cargo-enc/recordsize
NAME                  PROPERTY    VALUE    SOURCE
cargo-enc/recordsize  recordsize  1M       local
2RecordSize1024k-2018-06-15.png (58.9 KB) 2RecordSize1024k-2018-06-15.png Michael Reynolds, 06/15/2018 08:18 AM
1RecordSizeDefault-2018-06-15.png (64.5 KB) 1RecordSizeDefault-2018-06-15.png Michael Reynolds, 06/15/2018 08:18 AM
3RecordSizeInherit-1048576-2018-06-15.png (61.4 KB) 3RecordSizeInherit-1048576-2018-06-15.png Michael Reynolds, 06/15/2018 08:18 AM
zfsReported-2018-06-15.png (31.8 KB) zfsReported-2018-06-15.png Michael Reynolds, 06/15/2018 08:18 AM
Screen Shot 2018-06-26 at 10.23.20 AM.png (84.1 KB) Screen Shot 2018-06-26 at 10.23.20 AM.png Bonnie Follweiler, 06/26/2018 07:26 AM
Screen Shot 2018-06-26 at 10.24.17 AM.png (42.3 KB) Screen Shot 2018-06-26 at 10.24.17 AM.png Bonnie Follweiler, 06/26/2018 07:27 AM
18592
18595
18598
18601
19583
19588

Related issues

Related to FreeNAS - Bug #35993: Format dataset recordsize correctly in new UIDone

Associated revisions

Revision 2aa6e323 (diff)
Added by William Grzybowski over 2 years ago

fix(gui): showing recordsize of 1M Ticket: #34969

Revision dfa8f501 (diff)
Added by William Grzybowski over 2 years ago

fix(gui): handle M recordsize Pointed out by @yocaleb Ticket: #34969

Revision 02072273 (diff)
Added by William Grzybowski over 2 years ago

fix(gui): handle M recordsize Pointed out by @yocalebo Ticket: #34969

Revision ce0785c8 (diff)
Added by William Grzybowski over 2 years ago

fix(gui): showing recordsize of 1M Ticket: #34969

Revision ce8228af (diff)
Added by William Grzybowski over 2 years ago

fix(gui): handle M recordsize Pointed out by @yocalebo Ticket: #34969

Revision 3d8034a1 (diff)
Added by William Grzybowski about 2 years ago

fix(gui): showing recordsize of 1M Ticket: #34969

Revision 2920e89b (diff)
Added by William Grzybowski about 2 years ago

fix(gui): handle M recordsize Pointed out by @yocalebo Ticket: #34969

History

#1 Updated by Caleb St. John over 2 years ago

  • Description updated (diff)

#2 Updated by Dru Lavigne over 2 years ago

  • Project changed from TrueNAS to FreeNAS
  • Subject changed from webUI doesn't update when chaning recordsize of dataset to webUI doesn't update when changing recordsize of dataset
  • Category changed from GUI to Middleware
  • Assignee changed from Release Council to William Grzybowski
  • Seen in changed from 11.1-U5 to TrueNAS 11.1-U5
  • Migration Needed deleted (No)
  • Hide from ChangeLog deleted (No)
  • Support Department Priority deleted (0)

#3 Updated by Dru Lavigne over 2 years ago

  • Target version changed from Backlog to Backlog

#4 Updated by William Grzybowski over 2 years ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need additional information from Author

I cannot reproduce this in our 11.2 Nightlies, so perhaps this was already fixed? Could you or someone else try in a newer version to confirm?

#5 Updated by Michael Reynolds over 2 years ago

  • Status changed from Blocked to Failed Testing
  • Reason for Blocked changed from Need additional information from Author to Waiting for feedback

I created a new dataset named Bug-34969
Changed the Record Size from "Inherit (128k)
See 1RecordSizeDefault-2018-06-15.png
to Record Size 1024K
See 2RecordSize1024k-2018-06-15.png

Went into options to check dataset. The Record Size is Inherit (1048576)
See 3RecordSizeInherit-1048576-2018-06-15.png

zfs get recordsize reports 1M
see zfsReported-2018-06-15.png

1Mebibit equals 1024Kibibit
1024Kibibit equals 1048576Bits

So it looks like there is a couple of bugs here.
1st bug why is the new custom value listed as Inherit(1048576)
Seems the Inherit() shouldn't be there as it's no longer inherited?

2nd "bug" is an issue with the unit of measure used to display the values.

Looks to me that everything is in Mebibit/Kibibit/Bits not the more "normal" Megabytes/Kilobytes/Bytes that most people expect.

It's fine to use the forms used, but we should spell the entire value out Kibibit, not K for example.

I'd say we could/should even have a warning or tooltip, and a userguide entry explaining the measurement used.

#6 Updated by William Grzybowski over 2 years ago

Where are the screenshots?

#7 Updated by William Grzybowski over 2 years ago

You also forgot to mention the version used for testing.

#8 Updated by Michael Reynolds over 2 years ago

18592
18595
18598
18601

Apologies forgot the screenshots
This is using the latest FreeNAS nightly
FreeNAS-11.2-MASTER-201806150444

#9 Updated by William Grzybowski over 2 years ago

Michael Reynolds wrote:

Apologies forgot the screenshots
This is using the latest FreeNAS nightly
FreeNAS-11.2-MASTER-201806150444

We need it tested using legacy UI.

This is a TrueNAS ticket about 11.1-U5 (which is legacy UI).

#10 Updated by William Grzybowski over 2 years ago

Caleb, can you confirm this only happens with 1024K, but not 256K nor 512K?

#11 Updated by William Grzybowski over 2 years ago

  • Status changed from Failed Testing to In Progress
  • Target version changed from Backlog to 11.2-BETA1
  • Reason for Blocked deleted (Waiting for feedback)
  • Needs Merging changed from Yes to No

#13 Updated by William Grzybowski over 2 years ago

  • Status changed from In Progress to Ready for Testing

#14 Updated by Dru Lavigne over 2 years ago

  • Subject changed from webUI doesn't update when changing recordsize of dataset to Properly handle dataset recordsize of 1M

#15 Updated by Bonnie Follweiler about 2 years ago

19583
19588

I created a dataset with a record limit of 1M
In the old UI it shows Record Size 1M
In the New GUI it shows Record size inherit (1048576)

#16 Updated by Bonnie Follweiler about 2 years ago

  • Status changed from Failed Testing to Passed Testing
  • Needs QA changed from Yes to No

After talking to William - it Test Passed in FreeNAS-11.2-INTERNAL8
I will create a new ticket to address the formatting in the new GUI

#17 Updated by Dru Lavigne about 2 years ago

  • Status changed from Passed Testing to Done

#18 Updated by Dru Lavigne about 2 years ago

  • Related to Bug #35993: Format dataset recordsize correctly in new UI added

Also available in: Atom PDF