Project

General

Profile

Bug #35059

Active Directory binding continuously resets when monitoring is enabled

Added by Hal Haygood over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Warren Block
Category:
Documentation
Target version:
Seen in:
Severity:
Low Medium
Reason for Closing:
Not Applicable
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

My system is bound to a Windows Server 2016 domain for authc. If I enable monitoring in the AD settings, the bind resets itself every few minutes, which in turn restarts smbd, disconnecting all CIFS connections. It also behaves as if there are multiple processes doing the health check. If I disable monitoring, the AD connection works fine.

I've attached two logs. The first is /var/log/messages with normal logging (not verbose), showing how the connection is resetting. The second is with verbose logging enabled, starting when I click "Save" on the AD configuration dialog.


Related issues

Related to FreeNAS - Bug #33453: Fix unnecessary AD restarts caused by enabling service monitorDone

History

#1 Updated by Hal Haygood over 2 years ago

  • File log2 added

#2 Updated by Dru Lavigne over 2 years ago

  • Reason for Blocked set to Need additional information from Author

Does it bind correctly when "Enable Monitoring" is unchecked?

#3 Updated by Hal Haygood over 2 years ago

Yes, everything seems to work fine with it unchecked. It's been bound without errors for ~36 hours now.

#4 Updated by Dru Lavigne over 2 years ago

  • File deleted (log1)

#5 Updated by Dru Lavigne over 2 years ago

  • File deleted (log2)

#6 Updated by Dru Lavigne over 2 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Not Applicable
  • Reason for Blocked deleted (Need additional information from Author)

Hal: thanks for the update. I'll go ahead and close this ticket as unchecking that box seems to have resolved the issue for your scenario.

#7 Updated by Hal Haygood over 2 years ago

Dru, I appreciate you looking through this. My read is that the monitoring feature exists for a reason - to help systems that have binding stability issues - but that it's counterproductive if AD is already stable, because the monitoring is throwing a false positive. In that case, wouldn't it be prudent to put a warning into the info tooltip so that users with stable binds don't accidentally cause problems for themselves (like I did)?

#8 Updated by Dru Lavigne over 2 years ago

  • Category changed from OS to Documentation
  • Status changed from Closed to Unscreened
  • Assignee changed from Release Council to Warren Block
  • Target version changed from N/A to 11.2-RC2
  • Severity changed from New to Low Medium

Warren: please check the wording in the Guide and the tooltips for the legacy and new UIs.

#9 Updated by Dru Lavigne over 2 years ago

  • Related to Bug #33453: Fix unnecessary AD restarts caused by enabling service monitor added

#10 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.2-RC2 to 11.2-BETA3

#11 Updated by Dru Lavigne over 2 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from 11.2-BETA3 to N/A

Closing out this ticket as the underlying issue has been resolved for 11.1-U6 / 11.2-BETA2.

Also available in: Atom PDF