Project

General

Profile

Bug #3510

multipath does not work with enclosures when name gets to long

Added by stup ProS almost 7 years ago. Updated about 3 years ago.

Status:
Closed: Insufficient Info
Priority:
Nice to have
Assignee:
Josh Paetzel
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

hw:
supermicro jbod
LSI 9207 SAS HBA
a bunch of dual sas disks, sas enclosur eis connected with two sas ports.

steps to reproduce:
added some new dual sas devices to my freenas box,
reboot the server.
they do not show up in the multipath section within the webui

dmesg:

[root@freenas ~]# dmesg
Local NSM refuses to monitor vYellow.we.intern
make_dev_physpath_alias: WARNING - Unable to alias gptid/087b49fa-560b-11e3-9fa1-002219573d63 to enc@n5003048001e294fd/type@0/slot@e/elmdesc@Slot_14/gptid/087b49fa-560b-11e3-9fa1-002219573d63 - path too long
make_dev_physpath_alias: WARNING - Unable to alias gptid/089d7450-560b-11e3-9fa1-002219573d63 to enc@n5003048001e294fd/type@0/slot@e/elmdesc@Slot_14/gptid/089d7450-560b-11e3-9fa1-002219573d63 - path too long
make_dev_physpath_alias: WARNING - Unable to alias gptid/0945fdea-560b-11e3-9fa1-002219573d63 to enc@n5003048001e2947d/type@0/slot@e/elmdesc@Slot_14/gptid/0945fdea-560b-11e3-9fa1-002219573d63 - path too long
make_dev_physpath_alias: WARNING - Unable to alias gptid/09681fb5-560b-11e3-9fa1-002219573d63 to enc@n5003048001e2947d/type@0/slot@e/elmdesc@Slot_14/gptid/09681fb5-560b-11e3-9fa1-002219573d63 - path too long

added them via cli:
[root@freenas ~]# gmultipath label -v disk11 /dev/da21 /dev/da22
Done.

now freenas shows them within the web intefrace.

History

#1 Updated by Josh Paetzel almost 7 years ago

  • Status changed from Unscreened to Screened
  • Assignee set to Josh Paetzel
  • Target version set to 49

The error is unrelated.

Is this something you can experiment on?

#2 Updated by Josh Paetzel over 6 years ago

  • Status changed from Screened to Closed: Insufficient Info

Closing due to lack of feedback. If you get to a point where you can work on this reopen the bug please. I think your issue may be fixed in 9.2.1.5 btw.

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Category set to Middleware
  • Target version changed from 49 to N/A
  • Seen in changed from to N/A

Also available in: Atom PDF