Project

General

Profile

Feature #35107

Allow passing auxiliary arguments to rclone

Added by Vladimir Vinogradenko over 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
No priority
Assignee:
Lola Yang
Category:
GUI (new)
Target version:
Estimated time:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

New cloud sync task field: args

Title: Auxiliary arguments

Tooltip: These arguments will be passed to rclone.<br>See <a href="https://rclone.org/docs/">https://rclone.org/docs/&lt;/a> for help

This should be valid shell command so some client-side syntax highlighting and validation would be very nice.

example.png (57.1 KB) example.png Dru Lavigne, 07/27/2018 01:13 PM
23032

Related issues

Related to FreeNAS - Feature #26131: Add "Auxiliary arguments" field to middlewareDone
Is duplicate of FreeNAS - Feature #34735: Support all cloud sync services that rclone supports in new UIDone

History

#1 Updated by Vladimir Vinogradenko over 2 years ago

  • Related to Feature #26131: Add "Auxiliary arguments" field to middleware added

#2 Updated by Erin Clark over 2 years ago

  • Assignee changed from Erin Clark to Lola Yang

#3 Updated by Dru Lavigne over 2 years ago

  • Target version changed from Backlog to 11.2-BETA2

Erin: this is needed for feature parity.

#4 Updated by Lola Yang over 2 years ago

  • Status changed from Unscreened to In Progress

#5 Updated by Lola Yang over 2 years ago

  • Related to Feature #34735: Support all cloud sync services that rclone supports in new UI added

#6 Updated by Lola Yang over 2 years ago

  • Assignee changed from Lola Yang to Erin Clark

#7 Updated by Dru Lavigne over 2 years ago

  • Related to deleted (Feature #34735: Support all cloud sync services that rclone supports in new UI)

#8 Updated by Dru Lavigne over 2 years ago

  • Is duplicate of Feature #34735: Support all cloud sync services that rclone supports in new UI added

#9 Updated by Dru Lavigne over 2 years ago

  • Status changed from In Progress to Closed
  • Assignee changed from Erin Clark to Lola Yang
  • Target version changed from 11.2-BETA2 to N/A
  • Reason for Closing set to Duplicate Issue

#10 Updated by Dru Lavigne about 2 years ago

  • File example.png example.png added
  • Status changed from Closed to Unscreened
  • Target version changed from N/A to 11.2-BETA3
  • Reason for Closing deleted (Duplicate Issue)
23032

I'm not seeing an Auxiliary Arguments field in lastest nightly (see screenshot).

#11 Updated by Lola Yang about 2 years ago

#12 Updated by Lola Yang about 2 years ago

Dru Lavigne wrote:

I'm not seeing an Auxiliary Arguments field in lastest nightly (see screenshot).

Hi Dru, auxiliary arguments was hide till the 'engineer mode' is done. https://redmine.ixsystems.com/issues/36633

#13 Updated by Dru Lavigne about 2 years ago

  • Status changed from Unscreened to Blocked
  • Target version changed from 11.2-BETA3 to Backlog

#14 Updated by Dru Lavigne about 2 years ago

  • Target version changed from Backlog to Backlog

#15 Updated by Dru Lavigne about 2 years ago

  • Status changed from Blocked to Done

#16 Updated by Dru Lavigne about 2 years ago

  • Status changed from Done to Blocked

#17 Updated by Dru Lavigne about 2 years ago

  • Assignee changed from Lola Yang to Erin Clark
  • Target version changed from Backlog to 11.3

#19 Updated by Dru Lavigne about 2 years ago

  • Status changed from Blocked to Unscreened

#20 Updated by Dru Lavigne over 1 year ago

  • Target version changed from 11.3 to 11.3-BETA1

#21 Updated by Erin Clark over 1 year ago

  • Assignee changed from Erin Clark to Lola Yang

#22 Updated by Lola Yang over 1 year ago

  • Status changed from Unscreened to In Progress

#23 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

  • Blocked by deleted (Feature #36633: "Engineering mode" hotkey in UI)

#24 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF