Project

General

Profile

Bug #35275

Close websocket connection when navigating away from Jail Shell in new UI

Added by Rishabh Chauhan 10 months ago. Updated 9 months ago.

Status:
Done
Priority:
No priority
Assignee:
Lola Yang
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

observed in FreeNAS-11.2-MASTER-201806190452
after following the steps and consulting will william

1. After sshing into freenas:

When FreeNAS shell is open in the webui

freenas# ps ax | grep top | wc -l
2

When FreNAS shell is closed(moving to a new tab)

freenas# ps ax | grep top | wc -l
1

2. After creating iocage shell and navigating in and out,ssh and check

freenas# ps ax | grep iocage

19018 2 S+ 0:00.00 grep iocage
18834 26 Is 0:02.07 /usr/local/bin/python3.6 /usr/local/bin/iocage consol
18883 29 Is 0:02.07 /usr/local/bin/python3.6 /usr/local/bin/iocage consol
18955 33 Is 0:02.07 /usr/local/bin/python3.6 /usr/local/bin/iocage consol

bold should not be present although when i close the tab and open again the ouptput is this
freenas# ps ax | grep iocage
19114 2 S+ 0:00.00 grep iocage

after discussing with william, we concluded that the issue is with the new webui shell, not with the middleware hence filing a new ticket with the same for new GUI


Related issues

Related to FreeNAS - Bug #30870: Ensure shell is killed on connection closeDone
Has duplicate FreeNAS - Bug #37008: Terminal never exitsClosed

History

#1 Updated by Dru Lavigne 10 months ago

  • Related to Bug #30870: Ensure shell is killed on connection close added

#2 Updated by Dru Lavigne 10 months ago

  • Related to deleted (Bug #30870: Ensure shell is killed on connection close)

#3 Updated by Dru Lavigne 10 months ago

  • Related to Bug #30870: Ensure shell is killed on connection close added

#4 Updated by Dru Lavigne 10 months ago

  • Assignee changed from Release Council to Erin Clark
  • Target version changed from Backlog to 11.2-BETA2

#5 Updated by William Grzybowski 10 months ago

Just to add here to try make things more clear: websocket shell connection needs to be closed when you navigate away from Jail Shell.

#6 Updated by Erin Clark 10 months ago

  • Assignee changed from Erin Clark to Lola Yang

#7 Updated by Lola Yang 10 months ago

  • Status changed from Unscreened to In Progress
  • Assignee changed from Lola Yang to Erin Clark

#8 Updated by Dru Lavigne 10 months ago

  • Subject changed from Iocage shell doesnt close when navigated away from the iocage shell window in reference to #30870 to Close websocket connection when navigating away from Jail Shell in new UI
  • Assignee changed from Erin Clark to Lola Yang

#9 Updated by Lola Yang 10 months ago

  • Related to Bug #37008: Terminal never exits added

#10 Updated by Dru Lavigne 10 months ago

  • Related to deleted (Bug #37008: Terminal never exits)

#11 Updated by Dru Lavigne 10 months ago

  • Has duplicate Bug #37008: Terminal never exits added

#12 Updated by Dru Lavigne 10 months ago

  • Status changed from In Progress to Ready for Testing
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#13 Updated by Aaron St. John 9 months ago

  • Status changed from Ready for Testing to Blocked

So I've followed the same steps as given in the description and it always returns 1. Also, when I navigate into iocage shell and back out and run
ps ax | grep iocage
in ssh it returns
5422 2 S+ 0:00.00 grep iocage

#14 Updated by Aaron St. John 9 months ago

  • Status changed from Blocked to Passed Testing

After speaking to William, he believes this is normal and that testing has passed.

#15 Updated by Dru Lavigne 9 months ago

  • Status changed from Passed Testing to Done
  • Needs QA changed from Yes to No

Also available in: Atom PDF