Project

General

Profile

Bug #35338

Jail disappear from API v2

Added by Waqar Ahmed over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Brandon Schneider
Category:
Middleware
Target version:
Severity:
Low Medium
Reason for Closing:
Cannot Reproduce
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

From the new UI, if a jail is created with basic settings, changing only the dhcp and vnet option. They should be turned on. Then once the jail instance has been created, it should be started from the UI. If the page is refreshed after a couple of seconds, the jail disappears which was just made. API v2 fails to fetch it with jail.query making this likely a Middlewared issues instead of a UI one.

However, if the same process is repeated with iocage command line, the issue is not reproducible and everything works just fine.


Related issues

Related to FreeNAS - Bug #34771: Catch any exceptions when updating a propertyDone
Related to FreeNAS - Bug #34870: Add APIv2 tests for JailsDone

History

#1 Updated by Waqar Ahmed over 2 years ago

  • Related to Bug #34771: Catch any exceptions when updating a property added

#2 Updated by Waqar Ahmed over 2 years ago

  • Related to Bug #34870: Add APIv2 tests for Jails added

#3 Updated by Brandon Schneider over 2 years ago

  • Status changed from Unscreened to In Progress
  • Severity changed from New to Low Medium

#4 Updated by Brandon Schneider over 2 years ago

  • Status changed from In Progress to Closed
  • Reason for Closing set to Cannot Reproduce

Not an issue on the latest nightlies, confirmed Waqar no longer sees the behavior

#5 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.2-RC2 to N/A

Also available in: Atom PDF