Project

General

Profile

Bug #35404

Fix race condition in SMART

Added by Caleb St. John 10 months ago. Updated 8 months ago.

Status:
Done
Priority:
No priority
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Seen in:
Severity:
Med High
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

On 11.1-U5, I have identified a drive that is not compatible with smartd (usb drive).

If I go into View Disks, under Storage and check the "Enable S.M.A.R.T." checkbox, I receive an error message in the GUI that states "The service failed to restart.". I have attached a screenshot labelled "enabling_smart.png" showing the message.

This is expected behavior. If I go back into the webUI and UNCHECK the "Enable S.M.A.R.T." checkbox I receive the same "The service failed to restart" message in the webUI. I have attached a screenshot to this ticket laballed "disabling_smart.png" showing this message.
Even though after disabling SMART for the USB drive, the smartd service starts up as usual. The cli shows the smartd process running as normal.

root@truenas:~ # ps -auxwh | grep -v grep | grep smartd
root       43394    1.5  0.0  10704   4956  -  Ss   09:38     0:00.19 /usr/local/sbin/smartd -n -i 1800 -c /usr/local/etc/smartd.conf -p /var/run/smartd-daemon.pid

enabling_smart.png (5.85 KB) enabling_smart.png Caleb St. John, 06/20/2018 09:42 AM
enabling_smart.png (5.85 KB) enabling_smart.png Caleb St. John, 06/20/2018 09:42 AM
19063
19066

Associated revisions

Revision f6a7bff5 (diff)
Added by Vladimir Vinogradenko 10 months ago

fix(service): Fix race condition where StartNotify(verb="restart") reports success
(because pid file exists) before stop command has a chance to remove pid file

Ticket: #35404

Revision 7737e8c9 (diff)
Added by Vladimir Vinogradenko 10 months ago

fix(service): Fix race condition where StartNotify(verb="restart") reports success
(because pid file exists) before stop command has a chance to remove pid file

Ticket: #35404

History

#1 Updated by Caleb St. John 10 months ago

19063
19066

Attaching screenshots.

#2 Updated by Dru Lavigne 10 months ago

  • Category changed from OS to Middleware
  • Assignee changed from Release Council to William Grzybowski

#4 Updated by William Grzybowski 10 months ago

  • Assignee changed from William Grzybowski to Vladimir Vinogradenko

Vladimir can you investigate why it says the service failed to start even though it did?

Thanks

#5 Updated by Vladimir Vinogradenko 10 months ago

  • Status changed from Unscreened to Ready for Testing

#6 Updated by Vladimir Vinogradenko 10 months ago

#7 Updated by Dru Lavigne 10 months ago

  • Subject changed from webUI is stating smartd failed to restart when it actually did restart to Fix race condition in SMART

#10 Updated by Dru Lavigne 10 months ago

  • Project changed from TrueNAS to FreeNAS
  • Category changed from Middleware to Middleware
  • Target version changed from TrueNAS-11.1-U6.1 to 11.1-U6
  • Migration Needed deleted (No)
  • Hide from ChangeLog deleted (No)
  • Support Department Priority deleted (0)

#12 Updated by Dru Lavigne 9 months ago

  • Needs Merging changed from Yes to No

#13 Updated by Bonnie Follweiler 8 months ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Test Passed in FreeNAS-11.1-U6-INTERNAL3

#14 Updated by Dru Lavigne 8 months ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF