Project

General

Profile

Bug #35428

Disable RRD write cache when Reporting Database is unchecked

Added by Damian Szidiropulosz over 2 years ago. Updated about 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Alexander Motin
Category:
OS
Target version:
Severity:
Low Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Whenever the UI requests stats from a date range, the array returned always has a varying number of trailing undefined values. I spoke with William from the middleware team and it seems this is a problem with rrdtool's behavior so I'm assigning this ticket to OS/Services.


Related issues

Related to FreeNAS - Bug #41208: Upon every new login, Memory and CPU temp charts show a weird drop to 0Closed
Has duplicate FreeNAS - Bug #40804: Dashboard metrics failing to track CPU.Closed

Associated revisions

Revision 1f17df16 (diff)
Added by Alexander Motin about 2 years ago

Disable RRD write cache when ramdisk is used. It does not make much sense to cache writes to ramdisk, it has no wear, but disabling it makes graphs much more interactive. Ticket: #35428

Revision ecb0b4a4 (diff)
Added by Alexander Motin about 2 years ago

Disable RRD write cache when ramdisk is used. (#1508) It does not make much sense to cache writes to ramdisk, it has no wear, but disabling it makes graphs much more interactive. Ticket: #35428

History

#1 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Alexander Motin

#2 Updated by Alexander Motin over 2 years ago

  • Status changed from Unscreened to Screened
  • Severity changed from New to Low Medium

If I understand right what you are talking about, that is not a bug, but an optimization from collectd side to not kick disk storing RRDs with writes too often for every sample for every graph, since it would cause huge write amplification. May be it can be optimized depending on situation. We could completely disable that optimization when data are stored on tmpfs. Otherwise, for data stored on ZFS we could probably reduce ZFS recordsize for dataset storing RRDs from 128K to lets say 16K to reduce the write amplification.

Also IIRC collectd can be made to flush data to disk on request by sending it some signal (SIGHUP?), though not sure how useful is that in real life in case of constantly refreshing graphs.

#3 Updated by Alexander Motin about 2 years ago

  • Status changed from Screened to In Progress
  • Target version changed from 11.2-RC2 to 11.2-BETA2

I've disabled write caching when RRDs are stored on tmpfs ("Reporting Database" is unchecked), that should make graph much more interactive. The opposite case unfortunately does not have an easy solution, but I'll take another look whether it can be optimized somehow.

#4 Updated by Dru Lavigne about 2 years ago

#5 Updated by Dru Lavigne about 2 years ago

  • Subject changed from rrdtool stats return undefined values to Disable RRD write cache when Reporting Database is unchecked
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#7 Updated by Dru Lavigne about 2 years ago

  • Status changed from In Progress to Ready for Testing

#9 Updated by Aaron St. John about 2 years ago

  • Status changed from Ready for Testing to Passed Testing

Tested by first ensuring “Reporting Database” was unchecked in System > System Dataset. Then used mount to find that tmpfs on /var/db/collectd/rrd (tmpfs, local). Checked the contents of /etc/local/collectd.conf and found that the paramater CacheTimeout was not present.

#10 Updated by Dru Lavigne about 2 years ago

  • Status changed from Passed Testing to Done
  • Needs QA changed from Yes to No

#11 Updated by Dru Lavigne about 2 years ago

  • Has duplicate Bug #40804: Dashboard metrics failing to track CPU. added

#12 Updated by Dru Lavigne about 2 years ago

  • Related to Bug #41208: Upon every new login, Memory and CPU temp charts show a weird drop to 0 added

Also available in: Atom PDF