Project

General

Profile

Bug #35509

Fix bugs with IP choices and iSCSI portal IPs

Added by Paul Walker about 1 year ago. Updated 12 months ago.

Status:
Done
Priority:
No priority
Assignee:
Waqar Ahmed
Category:
Middleware
Target version:
Seen in:
Severity:
High
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

If a network configuration change is made you are unable to change the portal IP.
After setting up a test box I started iscsi setup with a dhcp config on the network interface, I proceeded to setup a static ip for the main interface in the network options. After this change was made I went back to change the portal IP for iscsi setup, at this time I was unable to select the new ip from the drop down in the iscsi portal configuration.
It error saying select a valid choice the DHCP address is no longer valid even though the drop down has the correct static IP populated and will not update the portal config.
Confirmed this is working properly in the legacy UI
Seen in FreeNAS-11.2-INTERNAL6


Related issues

Has duplicate FreeNAS - Bug #38913: New GUI things machine's own IP address is wrongClosed

Associated revisions

Revision 91184ad1 (diff)
Added by Waqar Ahmed about 1 year ago

This commit fixes a bug when updating iscsi portal ip values failed if the ip changed
Ticket: #35509

Revision c329a455 (diff)
Added by Waqar Ahmed about 1 year ago

This commit fixes a bug when updating iscsi portal ip values failed if the ip changed
Ticket: #35509

Revision adc733cc (diff)
Added by Waqar Ahmed about 1 year ago

iSCSI Portal IP bug fix

This commit fixes a bug when updating iscsi portal ip values failed if the ip changed
Ticket: #35509

History

#1 Updated by Paul Walker about 1 year ago

  • Subject changed from After making a newwork change you are unable to update the portal IP in iscsi setup to After making a network change you are unable to update the portal IP in iscsi setup

#2 Updated by Dru Lavigne about 1 year ago

  • Assignee changed from Joe Maloney to Erin Clark

#3 Updated by Erin Clark about 1 year ago

  • Assignee changed from Erin Clark to William Grzybowski

This looks like a middleware issue to me, any thoughts William?

#4 Updated by William Grzybowski about 1 year ago

  • Assignee changed from William Grzybowski to Erin Clark

He says its working in legacy UI, so does not look like the case.

The error states an IP not in the list is being passed to the API, why is that?

#5 Updated by Erin Clark about 1 year ago

  • Assignee changed from Erin Clark to Lola Yang

Any ideas on this one Lola?

#6 Updated by Lola Yang about 1 year ago

19342
19345

It should be a middleware issue, the payload looks correct. 10.211.1.109 is the old IP, 10.211.1.108 is the new IP. Please see the attached files.

#7 Updated by William Grzybowski about 1 year ago

  • Category changed from GUI (new) to Middleware
  • Assignee changed from William Grzybowski to Waqar Ahmed

Waqar, can you investigate, please?

#8 Updated by Waqar Ahmed about 1 year ago

  • Status changed from Unscreened to In Progress

#9 Updated by William Grzybowski about 1 year ago

  • Target version changed from 11.2-RC2 to 11.2-BETA2

#10 Updated by Waqar Ahmed about 1 year ago

  • Status changed from In Progress to Ready for Testing

#11 Updated by Dru Lavigne about 1 year ago

  • Subject changed from After making a network change you are unable to update the portal IP in iscsi setup to Fix iSCSI Portal IP bug
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#12 Updated by Paul Walker 12 months ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

IP is updating as expected in portal configuration.

#13 Updated by Dru Lavigne 12 months ago

  • Status changed from Passed Testing to Done

#14 Updated by William Grzybowski 12 months ago

  • Has duplicate Bug #38913: New GUI things machine's own IP address is wrong added

#15 Updated by Dru Lavigne 12 months ago

  • Subject changed from Fix iSCSI Portal IP bug to Fix bugs with iSCSI IP choices and portal IPs

#16 Updated by Dru Lavigne 12 months ago

  • Subject changed from Fix bugs with iSCSI IP choices and portal IPs to Fix bugs with IP choices and iSCSI portal IPs

Also available in: Atom PDF