Project

General

Profile

Bug #35551

Fix creating zvol with volblocksize

Added by Paul Walker about 1 year ago. Updated 12 months ago.

Status:
Done
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
Low Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

While trying to change the zvol size in legacy UI it appears to take affect but does not.
If I try to edit the zvol size it applies the changes but the size of the volume does not change.
Original zvol size was 20GB Editing to change to 25GB. It appears to have normal behavior when making the changes but the size does not change.

tank/t1 74072379968 22148808704 0 553536 22148255168 0
tank/t2 74072850176 22148808704 0 83328 22148725376 0
freenas#

zvol size.PNG (17.4 KB) zvol size.PNG Paul Walker, 06/21/2018 01:40 PM
19240

Related issues

Related to FreeNAS - Bug #35542: Fix traceback when updating zvol sizeDone
Related to FreeNAS - Feature #34636: Reload iSCSI when zvol size changes on legacy UIDone
Has duplicate FreeNAS - Bug #35554: Zvol size does not update from new UIClosed

Associated revisions

Revision 1efc890f (diff)
Added by William Grzybowski about 1 year ago

Fix creating zvol with volblocksize

This will set correct refreservation allowing to to be resized.

Ticket: #35551

History

#1 Updated by William Grzybowski about 1 year ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Waiting for feedback

Did you create the zvol in new UI?

#2 Updated by Paul Walker about 1 year ago

Yes it was created in the new UI

#3 Updated by Paul Walker about 1 year ago

I can confirm that if the zvol is created in the legacy UI and edited in the legacy UI this works properly. If you create in the new UI and try to edit in the old UI you see the bad behavior. I attempted this because trying to edit the zvol size in the new GUI results in a traceback.

#4 Updated by William Grzybowski about 1 year ago

  • Has duplicate Bug #35554: Zvol size does not update from new UI added

#5 Updated by William Grzybowski about 1 year ago

  • Status changed from Blocked to In Progress
  • Target version changed from 11.2-RC2 to 11.2-BETA2

#6 Updated by William Grzybowski about 1 year ago

  • Severity changed from New to Low Medium

#7 Updated by Dru Lavigne 12 months ago

  • Target version changed from 11.2-BETA2 to 11.2-BETA1
  • Needs QA changed from No to Yes
  • Needs Merging changed from No to Yes

#8 Updated by William Grzybowski 12 months ago

  • Status changed from In Progress to Ready for Testing

#9 Updated by William Grzybowski 12 months ago

  • Reason for Blocked deleted (Waiting for feedback)
  • Needs Merging changed from Yes to No

#10 Updated by Dru Lavigne 12 months ago

  • Subject changed from Zvol size change does not go into effect to Fix creating zvol with volblocksize

#11 Updated by Dru Lavigne 12 months ago

  • Related to Bug #35542: Fix traceback when updating zvol size added

#12 Updated by Paul Walker 12 months ago

  • Status changed from Ready for Testing to Failed Testing
  • Needs QA changed from Yes to No

This issue is still seen in FreeNAS-11.2-INTERNAL12

#13 Updated by William Grzybowski 12 months ago

  • Status changed from Failed Testing to Ready for Testing

I believe INTERNAL12 does not include the fix because it was an incremental build.

Can you please try again with INTERNAL13? Also make sure its a new zvol, not an existing one.

#14 Updated by Dru Lavigne 12 months ago

  • Needs QA changed from No to Yes

#15 Updated by Bonnie Follweiler 12 months ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Passed Testing in FreeNAS 11.2-INTERNAL13

#16 Updated by Dru Lavigne 12 months ago

  • Status changed from Passed Testing to Done

#17 Updated by Dru Lavigne 12 months ago

  • Related to Feature #34636: Reload iSCSI when zvol size changes on legacy UI added

Also available in: Atom PDF