Project

General

Profile

Bug #35599

Don't check peer_secret if peer_user isn't supplied in Sharing -> iSCSI -> Authorized Access

Added by Warren Block about 1 year ago. Updated 12 months ago.

Status:
Done
Priority:
No priority
Assignee:
Brandon Schneider
Category:
Middleware
Target version:
Severity:
Med High
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Trying to add an Authorized access with Sharing/iSCSI/Authorized Access/Add without a Peer or Peer Secret says "Peer Secret must be between 12 and 16 characters."
After entering a peer secret, it says "The peer user is required if you set a peer secret."

The validation on these fields is a little confused. Peer Secret should only be required if Peer is entered.


Related issues

Related to FreeNAS - Bug #38165: Iscsi Chap Secret doesn's work anymore.Closed
Is duplicate of FreeNAS - Bug #36658: Sharing/iSCSI/Auth/Add: Peer Secret is treated as a mandatory field, but the UI says it is notClosed

Associated revisions

Revision a3e600a6 (diff)
Added by Brandon Schneider about 1 year ago

fix(sharing/iscsi): Don't check peer_secret if peer_user isn't supplied

Tighten up the logic and return early if the peer user is not supplied.

Ticket: #35599

Revision 465f40c7 (diff)
Added by Brandon Schneider about 1 year ago

fix(sharing/iscsi): Don't check peer_secret if peer_user isn't supplied (#1456)

Tighten up the logic and return early if the peer user is not supplied.

Ticket: #35599

History

#1 Updated by Erin Clark about 1 year ago

  • Assignee changed from Erin Clark to Lola Yang

#2 Updated by Lola Yang about 1 year ago

  • Status changed from Unscreened to In Progress

#3 Updated by Lola Yang about 1 year ago

19748
19753

It's a middleware issue. please see the attached payload and response.

#4 Updated by Lola Yang about 1 year ago

19758
19763

after entering a peer secret, get error "The peer user is required if you set a peer secret."

#5 Updated by William Grzybowski about 1 year ago

  • Assignee changed from William Grzybowski to Brandon Schneider
  • Target version changed from Backlog to 11.2-BETA2
  • Severity changed from New to Med High
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#6 Updated by William Grzybowski about 1 year ago

Lola, in the first error you're not sending `peeruser` but you're sending peersecret, so the error seems accurate.

Brandon, seems like we need to fix at least the second error. peeruser is not send and it complains about peersecret.

#7 Updated by Brandon Schneider about 1 year ago

  • Status changed from Unscreened to In Progress

#8 Updated by Brandon Schneider about 1 year ago

PR: https://github.com/freenas/freenas/pull/1456

DESC: Make sure the validation returns if peer user is not set
RISK: Low
ACCEPTANCE: It correctly doesn't complain about peer secret if the peer user is not supplied

#9 Updated by Lola Yang about 1 year ago

  • Is duplicate of Bug #36658: Sharing/iSCSI/Auth/Add: Peer Secret is treated as a mandatory field, but the UI says it is not added

#10 Updated by Dru Lavigne about 1 year ago

  • Status changed from In Progress to Closed

#11 Updated by Dru Lavigne about 1 year ago

  • Status changed from Closed to In Progress

#12 Updated by Brandon Schneider about 1 year ago

  • Status changed from In Progress to Ready for Testing

DESC: Fix invalid validation checking when peer_user isn't supplied.
RISK: Low
ACCEPTANCE: Don't supply peer_user, and you won't get told to supply peer_secret

#13 Updated by Dru Lavigne about 1 year ago

  • Subject changed from Sharing/iSCSI/Authorized Access/Add requires peer secret even when peer is not entered to Don't check peer_secret if peer_user isn't supplied in Sharing -> iSCSI -> Authorized Access

#14 Updated by Dru Lavigne about 1 year ago

  • Related to Bug #38165: Iscsi Chap Secret doesn's work anymore. added

#15 Updated by Michael Reynolds 12 months ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

I am able to add a User and Secret without entering a Peer User or Peer Secret

#16 Updated by Dru Lavigne 12 months ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF