Project

General

Profile

Bug #35602

dtrace fails to load in FreeNAS

Added by Joe Maloney almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Alexander Motin
Category:
OS
Target version:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Using dtrace will fail in FreeNAS:

FreeBSD fncertified.ad01.tn.ixsystems.com 11.1-STABLE FreeBSD 11.1-STABLE #0 854e3946a(freenas/11-stable): Thu Jun 21 01:43:51 EDT 2018     root@mp20.tn.ixsystems.com:/freenas-11-nightlies/freenas/_BE/objs/freenas-11-nightlies/freenas/_BE/os/sys/FreeNAS.amd64  amd64

root@fncertified:~ # dtrace -n 'proc:::exec-success { trace(curpsinfo->pr_psargs); }'
dtrace: invalid probe specifier proc:::exec-success { trace(curpsinfo->pr_psargs); }: "/usr/lib/dtrace/ip.d", line 112: failed to copy typedef in6_addr_t source type: Type information is in parent and unavailable


Using dtrace in TrueNAS with same kernel version appears to work fine:
FreeBSD x20qa1.tn.ixsystems.com 11.1-STABLE FreeBSD 11.1-STABLE #4 r325575+854e3946a(freenas/11-stable): Fri Jun  8 23:53:37 EDT 2018     root@mp20.tn.ixsystems.com:/truenas-11-nightlies/freenas/_BE/objs/truenas-11-nightlies/freenas/_BE/os/sys/TrueNAS.amd64  amd64

root@x20qa1:~ # dtrace -n 'proc:::exec-success { trace(curpsinfo->pr_psargs); }' 
dtrace: description 'proc:::exec-success ' matched 1 probe
CPU     ID                    FUNCTION:NAME
 10  53479                none:exec-success   /bin/sh -c /sbin/zpool list -H | grep -v freenas-boot
  1  53479                none:exec-success   grep -v freenas-boot             
  2  53479                none:exec-success   /sbin/zpool list -H              
 10  53479                none:exec-success   /bin/sh -c /sbin/zpool list -H | grep -v freenas-boot
  7  53479                none:exec-success   grep -v freenas-boot             
  9  53479                none:exec-success   /sbin/zpool list -H              
  5  53479                none:exec-success   /bin/sh -c /sbin/zpool list -H | grep -v freenas-boot
  9  53479                none:exec-success   /sbin/zpool list -H             


Related issues

Is duplicate of FreeNAS - Bug #34609: Move FireWire drivers to modules and remove COMPAT_43TTY from kernel configDone

History

#1 Updated by Joe Maloney almost 2 years ago

  • Seen in changed from 11.1-BETA1 to 11.2-BETA1

#2 Updated by Joe Maloney almost 2 years ago

  • Seen in changed from 11.2-BETA1 to Master - FreeNAS Nightlies

#3 Updated by Dru Lavigne almost 2 years ago

  • Category set to OS
  • Assignee changed from Release Council to Alexander Motin

#4 Updated by Alexander Motin almost 2 years ago

  • Is duplicate of Bug #34609: Move FireWire drivers to modules and remove COMPAT_43TTY from kernel config added

#5 Updated by Alexander Motin almost 2 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Duplicate Issue
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

Also available in: Atom PDF