Project

General

Profile

Bug #35626

Convert VMware Snapshot page to websocket in new UI

Added by Paul Walker about 1 year ago. Updated 12 months ago.

Status:
Done
Priority:
No priority
Assignee:
Paul Walker
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

While testing #33021 I was able to confirm that vmware-snapshots is not working properly. Its is connecting to the host and fetching datastores properly but when a snapshot is taken on the FreeNAS side I do not see the creation and deleting on the snapshots on the esxi host side. This seems to be isolated to the new GUI as testing in the legacy UI appears to be working as expected.


Subtasks

Bug #35834: Fix traceback when editing VMware Snapshot taskDoneWaqar Ahmed

Related issues

Related to FreeNAS - Feature #32673: Convert Storage:VMWare Snapshots to MiddlewaredDone
Related to FreeNAS - Bug #36238: Add VMware sync support for snapshots to APIv1Done
Blocked by FreeNAS - Bug #38565: Fix save action while creating VMware snapshot in new UIDone

Associated revisions

Revision 58358a0c (diff)
Added by vaibhav-rbs about 1 year ago

converting vmware snapshot page to websocket.

Ticket: #35626

Revision 3546999f (diff)
Added by vaibhav-rbs about 1 year ago

converting vmware snapshot page to websocket.

Ticket: #35626
(cherry picked from commit 58358a0cfa79662a378e6f06d1024d60f08eb95a)

History

#1 Updated by Erin Clark about 1 year ago

  • Assignee changed from Erin Clark to Vaibhav Chauhan

#2 Updated by Vaibhav Chauhan about 1 year ago

  • Status changed from Unscreened to In Progress

#3 Updated by Vaibhav Chauhan about 1 year ago

WIP branch https://github.com/freenas/webui/tree/FIX-35626, it has all the changes needed waiting for corresponding middleware fixes to be in nightlies so that I can test it.

#4 Updated by Vaibhav Chauhan about 1 year ago

  • Related to Bug #36238: Add VMware sync support for snapshots to APIv1 added

#5 Updated by Dru Lavigne about 1 year ago

  • Related to Feature #32673: Convert Storage:VMWare Snapshots to Middlewared added

#6 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.2-RC2 to 11.2-BETA2

#7 Updated by Vaibhav Chauhan about 1 year ago

this PR ready for Review, please refer at the notes https://github.com/freenas/webui/pull/931 in PR

#8 Updated by Vaibhav Chauhan about 1 year ago

  • Status changed from In Progress to Ready for Testing

corresponding https://github.com/freenas/webui/pull/931 was already merged so this is ready for testing.

#9 Updated by Dru Lavigne about 1 year ago

  • Related to deleted (Bug #36238: Add VMware sync support for snapshots to APIv1)

#10 Updated by Dru Lavigne about 1 year ago

  • Is duplicate of Bug #36238: Add VMware sync support for snapshots to APIv1 added

#11 Updated by Dru Lavigne about 1 year ago

  • Is duplicate of deleted (Bug #36238: Add VMware sync support for snapshots to APIv1)

#12 Updated by Dru Lavigne about 1 year ago

  • Related to Bug #36238: Add VMware sync support for snapshots to APIv1 added

#13 Updated by Dru Lavigne about 1 year ago

  • Subject changed from vmware snapshot not getting created on esxi host to Convert WMware Snapshot page to websocket in new UI

#14 Updated by Michael Reynolds 12 months ago

  • Subject changed from Convert WMware Snapshot page to websocket in new UI to Convert VMware Snapshot page to websocket in new UI

#15 Updated by Paul Walker 12 months ago

  • Status changed from Ready for Testing to Blocked
  • Reason for Blocked set to Other: make a note in comments

Blocked while waiting for Bug #38565

#16 Updated by Dru Lavigne 12 months ago

  • Blocked by Bug #38565: Fix save action while creating VMware snapshot in new UI added

#17 Updated by Dru Lavigne 12 months ago

  • Status changed from Blocked to Unscreened
  • Reason for Blocked deleted (Other: make a note in comments)

#18 Updated by Paul Walker 12 months ago

  • Status changed from Unscreened to Passed Testing
  • Assignee changed from Vaibhav Chauhan to Paul Walker

This is working as expected.

#19 Updated by Dru Lavigne 12 months ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF