Project

General

Profile

Bug #35632

Prompt user to fix Cloud Credential in new UI when credential check fails

Added by Warren Block over 1 year ago. Updated over 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Lola Yang
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Creating a cloud sync task, when a cloud sync credential is set, the system immediately attempts to connect to that provider.

This can cause long delays when creating a cloud sync task or even make it impossible to define a cloud sync task.

It would be better to have a "test connection" button or something similar. Let the user choose any existing cloud credentials, but do not attempt to connect to that provider unless tested or the cloud sync task runs.

cloudsync_msg.png (169 KB) cloudsync_msg.png Aaron St. John, 08/10/2018 07:26 AM
24060

History

#1 Updated by Erin Clark over 1 year ago

  • Assignee changed from Erin Clark to Lola Yang

#2 Updated by Dru Lavigne over 1 year ago

  • Target version changed from Backlog to 11.2-RC2

#3 Updated by Dru Lavigne over 1 year ago

  • Target version changed from 11.2-RC2 to 11.2-BETA3

#4 Updated by Lola Yang over 1 year ago

It only happens if the cloud credential provider required a bucket, and a valid bucket is also required for creating a cloud sync task.
We can discuss this on the demo meeting (July 23).

#6 Updated by Erin Clark over 1 year ago

UI meeting: for now add a link to go back to cloud credentials on the error message that lets the user go back and fix their credentials.

Eventually we may want to add a wizard for cloud sync/credentials but this will need further design.

#7 Updated by Lola Yang over 1 year ago

  • Status changed from Unscreened to In Progress

#8 Updated by Erin Clark over 1 year ago

  • Status changed from In Progress to Ready for Testing

#9 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Cloud Sync Tasks try to connect to cloud provider immediately to Prompt user to fix Cloud Credential in new UI when credential check fails
  • Needs Merging changed from Yes to No

#10 Updated by Aaron St. John over 1 year ago

24060

Tested on FreeNAS-11.2-MASTER-201808090859

Test process:
1. I created a credential for every cloud service available in the UI. I entered fake, incorrect values for each one.
2. Went to Tasks > Cloud Sync Tasks > Add.
3. I then tried to set up the tasks with each of the created credentials.
4. I found that I would get this error message (see screenshot) almost immediately after selecting certain credentials from the "Credentials" drop down For example "S3", "B2", "AZUREBLOB", etc. However, some did not. For example, "FTP", "BOX", "DROPBOX", etc.

The reason I'm marking as blocked is because I'm not sure if this is the desired result. If it is, mark as passed.

#11 Updated by Dru Lavigne over 1 year ago

  • Status changed from Blocked to Failed Testing

#12 Updated by Aaron St. John over 1 year ago

  • Status changed from Failed Testing to Passed Testing
  • Needs QA changed from Yes to No

After having a discussion with Erin, this was deemed the expected behaviour. Some cloud services handle credentials differently.

#13 Updated by Aaron St. John over 1 year ago

  • Needs Doc changed from Yes to No

#14 Updated by Dru Lavigne over 1 year ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF