Project

General

Profile

Bug #35638

Show plugin installation progress in new UI

Added by Warren Block about 2 years ago. Updated about 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Lola Yang
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

While a plugin is being installed, only a spinner is shown. There is no way for the user to tell how long it will take or if the system is actually doing anything.

This should be a status display for the download and install of the plugin jail. If we already have that for jails, the code can be reused.

The attached screenshot was taken after about two minutes in the plugin install. It finally finished installing after about 4.5 minutes.

plugin-install.png (73.3 KB) plugin-install.png Warren Block, 06/22/2018 01:25 PM
plugin_install_progress.png (148 KB) plugin_install_progress.png Aaron St. John, 08/13/2018 10:38 AM
19327
24160

Related issues

Is duplicate of FreeNAS - Feature #34594: Show plugin install process instead of just "please wait"Closed
Blocked by FreeNAS - Feature #36948: Use callback to return iocage plugin progressDone

History

#1 Updated by Erin Clark about 2 years ago

  • Assignee changed from Erin Clark to Lola Yang

#2 Updated by Dru Lavigne about 2 years ago

  • Blocked by Feature #36948: Use callback to return iocage plugin progress added

#3 Updated by Dru Lavigne about 2 years ago

  • Status changed from Unscreened to Blocked
  • Target version changed from Backlog to 11.2-RC2
  • Reason for Blocked set to Dependent on a related task to be completed

#5 Avatar?id=13649&size=24x24 Updated by Ben Gadd about 2 years ago

  • Target version changed from 11.2-RC2 to Backlog

#6 Updated by Dru Lavigne about 2 years ago

  • Target version changed from Backlog to 11.2-BETA3

#7 Updated by Dru Lavigne about 2 years ago

  • Status changed from Blocked to Not Started
  • Reason for Blocked deleted (Dependent on a related task to be completed)

#8 Updated by Lola Yang about 2 years ago

  • Status changed from Not Started to In Progress

#9 Updated by Erin Clark about 2 years ago

  • Status changed from In Progress to Ready for Testing

#10 Updated by Erin Clark about 2 years ago

  • Status changed from Ready for Testing to In Progress

#11 Updated by Erin Clark about 2 years ago

  • Status changed from In Progress to Ready for Testing

#12 Updated by Dru Lavigne about 2 years ago

  • Subject changed from No status is shown when a plugin is being installed to Show plugin installation progress in new UI
  • Needs Merging changed from Yes to No

#13 Updated by Aaron St. John about 2 years ago

24160

Tested on FreeNAS-11.2-MASTER-201808130848

See screenshot.

#14 Updated by Dru Lavigne about 2 years ago

  • Status changed from Passed Testing to Done

#15 Updated by Lola Yang about 2 years ago

  • Is duplicate of Feature #34594: Show plugin install process instead of just "please wait" added

Also available in: Atom PDF