Project

General

Profile

Bug #35785

Avatar?id=55038&size=50x50

When importing a pool, do not get disks of UNAVAIL/OFFLINE vdevs

Added by Zackary Welch over 2 years ago. Updated about 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When creating an encrypting pool and detaching it, one becomes unable to reattach/import the pool. The pool is not listed for import. In addition, I created a pool with three disks, but only one is available to decrypt. A new pool cannot be created with the disks because one already exists. 'zpool list' shows the pool as Unavilable, and I cannot attach it.

The attached video is pretty long, since I create the pool and show I can lock/unlock the pool before detaching it and trying to import it.

output.mp4 (4.2 MB) output.mp4 Zackary Welch, 06/25/2018 01:57 PM

Related issues

Related to FreeNAS - Feature #29096: Add API to decrypt disks and import poolDone

History

#1 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to William Grzybowski

#2 Updated by Dru Lavigne over 2 years ago

  • Related to Feature #29096: Add API to decrypt disks and import pool added

#3 Updated by William Grzybowski over 2 years ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Waiting for feedback

I cannot reproduce this using latest nightlies.

Can you attach your save debug after experiencing the problem?

Or give access to that VM in addition to the key and passphrase?

#4 Avatar?id=55038&size=24x24 Updated by Zackary Welch over 2 years ago

  • File debug.tgz added

This occurs on the old and new UI. Attached is the debug from my most recent reproduction. I created an Encrypted pool with 1 drive and no passcode. When I detached the pool and tried to import it, no drives were available to decrypt and the pool did not show up on import. This occurs even if I set a passcode or if I include multiple drives. I sent you the vm with passcode.

#5 Updated by Dru Lavigne over 2 years ago

  • Status changed from Blocked to Unscreened
  • Reason for Blocked deleted (Waiting for feedback)

#6 Updated by William Grzybowski over 2 years ago

  • Status changed from Unscreened to In Progress
  • Target version changed from Backlog to 11.2-BETA2

This is a side effect of the disks being used in freenas-boot once and not cleanly removed.

#7 Updated by William Grzybowski over 2 years ago

  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#8 Updated by William Grzybowski about 2 years ago

  • Status changed from In Progress to Ready for Testing

#9 Updated by Dru Lavigne about 2 years ago

  • File deleted (debug.tgz)

#10 Updated by Dru Lavigne about 2 years ago

  • Subject changed from Unable to import encrypted zpool after detachment to When importing a pool, do not get disks of UNAVAIL/OFFLINE vdevs

#11 Avatar?id=55038&size=24x24 Updated by Zackary Welch about 2 years ago

  • Status changed from Ready for Testing to Failed Testing
  • Needs QA changed from Yes to No

I can now properly import an encrypted pool and the disks show up correctly, so this passes.

#12 Updated by Dru Lavigne about 2 years ago

  • Status changed from Failed Testing to Done

Also available in: Atom PDF