Project

General

Profile

Bug #36183

Fix corruption of first byte in AFP_AfpInfo stream/xattr in Samba

Added by Dru Lavigne over 1 year ago. Updated over 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
John Hixson
Category:
OS
Target version:
Seen in:
Severity:
High
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
ZCX-891-77675
Hardware Configuration:
ChangeLog Required:
No

Description


Related issues

Copied from FreeNAS - Bug #34134: Fix corruption of first byte in AFP_AfpInfo stream/xattr in SambaDone

History

#1 Updated by Dru Lavigne over 1 year ago

  • Copied from Bug #34134: Fix corruption of first byte in AFP_AfpInfo stream/xattr in Samba added

#2 Updated by Dru Lavigne over 1 year ago

  • Target version changed from 11.1-U6 to 11.2-BETA2

#3 Updated by Dru Lavigne over 1 year ago

  • File deleted (old_streams_xattr.pcap)

#4 Updated by Dru Lavigne over 1 year ago

  • File deleted (new_streams_xattr.pcap)

#5 Updated by Dru Lavigne over 1 year ago

  • File deleted (Finder Refresh.zip)

#6 Updated by Dru Lavigne over 1 year ago

  • Status changed from Unscreened to Ready for Testing
  • Reason for Blocked deleted (Other: make a note in comments)

#7 Updated by Dru Lavigne over 1 year ago

  • Target version changed from 11.2-BETA2 to 11.2-BETA1

#8 Updated by Dru Lavigne over 1 year ago

  • Status changed from Ready for Testing to Done
  • Needs QA changed from Yes to No

#9 Updated by Dru Lavigne over 1 year ago

  • Status changed from Done to In Progress

#11 Updated by Dru Lavigne over 1 year ago

  • Description updated (diff)

#12 Updated by Dru Lavigne over 1 year ago

  • Status changed from In Progress to Ready for Testing
  • Needs QA changed from No to Yes

#15 Updated by Timur Bakeyev over 1 year ago

  • Description updated (diff)

#17 Updated by Andrew Walker over 1 year ago

  • File osx_xattr_write.pcap added

I encountered problems with original streams_xattr and the revisions to trans2.c (i.e. https://github.com/freenas/samba/pull/59):
Steps to reproduce:
1) generate file with large ADS (6MB or more) on FreeNAS server as follows: "cat [large file] | setextattr -i user DosStream.large_xattr:$DATA' [test file]"
2) mount smb share from OSX 10.13 client, "cd /Volumes/SHARE", and "xattr -p large_xattr [test file] | wc -c" to get size of xattr. Compare with size reported locally on freenas server "getextattr -q user 'DosStream.large_xattr:$DATA' [test file] | wc -c"
3) copy test file to Desktop of OSX client and verify size.
4) copy test file from Desktop of OSX client back to SMB share and verify size.

Step (2) on my OSX client showed length of ADS truncated to 1.0MB.
Step (3) Copy on Desktop showed length of ADS truncated to 1.0MB
Step (4) New copy on FreeNAS server showed length of ADS truncated to 4KB.

Pcap of (4) attached to ticket.

#18 Updated by Dru Lavigne over 1 year ago

  • Status changed from Ready for Testing to Failed Testing

#19 Updated by Timur Bakeyev over 1 year ago

  • Assignee changed from Timur Bakeyev to John Hixson

Passing this to John, as I have nothing to do with it.

#20 Updated by Andrew Walker over 1 year ago

  • File windows_osx.pcap added
  • File osx_xattr_write3.pcap added

OSX read from Windows server also stops after first MB. Possibly OSX SMB client bug.

#21 Updated by John Hixson over 1 year ago

Andrew & I are working on this. We have determined this to be a Mac OS issue. It may not be a big deal but we're still digging into this. I don't know if this is a release blocker yet or not, since Andrews testing methodology isn't a very good one and I'm working on some better testing tools for this. Large EA's are confirmed working on windows. I'm sure Andrew will post more as we find more ;-) This problem occurs with or without the previous vfs_streams_xattr code.

#23 Updated by John Hixson over 1 year ago

So there isn't really a problem here. Large EA's work fine. The only "problem" that happens is when a file with a large EA over what is a predefined size is copied to the local file system, it gets truncated. This isn't the general use case and this has worked this way all along. I don't even think this can be classified as a bug. I think we are good to go here and there are no more show stoppers.

#24 Updated by Dru Lavigne over 1 year ago

  • Status changed from Failed Testing to Done

#25 Updated by Dru Lavigne over 1 year ago

  • File deleted (osx_xattr_write.pcap)

#26 Updated by Dru Lavigne over 1 year ago

  • File deleted (windows_osx.pcap)

#27 Updated by Dru Lavigne over 1 year ago

  • File deleted (osx_xattr_write3.pcap)

#28 Updated by Dru Lavigne over 1 year ago

  • Needs QA changed from Yes to No

Also available in: Atom PDF