Project

General

Profile

Bug #36223

Allow upgrades on systems where grub is the only fstab entry

Added by Nick Wolff 10 months ago. Updated 10 months ago.

Status:
Done
Priority:
No priority
Assignee:
Nick Wolff
Category:
OS
Target version:
Severity:
High
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Reproduction:
Install 9.10.2u1 * I did uefi not sure if that's needed to break this
Boot installed system once
Boot 11.2beta1-internal11 iso
Upgrade system from installer by upgrading into new boot envirment
---------------

System reports upgrade has failed. See image for exact message
---------------

Reproduced on physical system and on VM

failed-upgrade.png (14.2 KB) failed-upgrade.png Nick Wolff, 06/28/2018 01:19 PM
19893

Associated revisions

Revision eeb48d54 (diff)
Added by Nick "darkfiberiru" Wolff 10 months ago

fix(installer): Allow upgrades on system where grub is the only /etc/… (#1457)

  • fix(installer): Allow upgrades on system where grub is the only /etc/fstab entry
    Ticket: #35863
  • Updating iso install upgrade codepath to match upgrade on running system
    Ticket: #36223

Updated to match following ix-bsdloader fixes
3358cf853677330dfc70eed5cc55d1091dc2dd71
d807f7a19b39ecfc7649868f0797d597828c859b

History

#1 Updated by Nick Wolff 10 months ago

  • Description updated (diff)

#2 Updated by Sean Fagan 10 months ago

  • Description updated (diff)

That kinda looks like the USB device timed out, but I'm not sure if that's what caused the installation failure.

#3 Updated by Nick Wolff 10 months ago

The USB info was printed a while after this failed. This is installing via a virtual iso via bhyve. Also have tested over ipmi iso on physical machine. Both setups have no issue installing just the upgrade.

#4 Updated by Nick Wolff 10 months ago

  • Description updated (diff)
  • Assignee changed from Alexander Motin to Nick Wolff

#5 Updated by Nick Wolff 10 months ago

After discussion with mav it looks like we made some alterations to the freenas upgrade progress for a running system that we didn't for the iso process. I'm updating my PR to cover this and talking to kmoore who did this work.

#6 Updated by Dru Lavigne 10 months ago

  • Subject changed from Upgrade via iso into new boot enviroment. to Allow upgrades on systems where grub is the only fstab entry
  • Status changed from Unscreened to Ready for Testing
  • Target version changed from Backlog to 11.2-BETA1
  • Seen in changed from 11.2-BETA1 to Master - FreeNAS Nightlies
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#7 Updated by Nick Wolff 10 months ago

  • Status changed from Ready for Testing to Passed Testing

Upgrades fixed.

Still might need to do further research on whether rolling back systems work

#8 Updated by Dru Lavigne 10 months ago

  • Status changed from Passed Testing to Done
  • Needs QA changed from Yes to No

Also available in: Atom PDF