Project

General

Profile

Bug #36338

Avatar?id=55038&size=50x50

Not a string error when editing Cloud Sync Task

Added by Zackary Welch about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
No priority
Assignee:
Lola Yang
Category:
GUI (new)
Target version:
Seen in:
Severity:
Low Medium
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Whenever I try to edit a Cloud Sync Task, I get a "Not a string" error upon saving. This appears for any of the quick schedule modes. For example, if I create a task and choose Hourly, then I can choose any value for Minutes and it will save. When I go to edit, if I change nothing, I still get a "[minute] not a string" error when saving. If I change minute to any reasonable value, it will save. This also applies to Hour.

It's important to note that I can save the task just fine using whatever Quick Schedule and I get no "not a string" errors. This only happens when I edit the Cloud Sync Task.

afterchangingboth.png (22.6 KB) afterchangingboth.png Zackary Welch, 06/29/2018 01:23 PM
Hour.png (52.3 KB) Hour.png Zackary Welch, 06/29/2018 01:23 PM
minute.png (52.7 KB) minute.png Zackary Welch, 06/29/2018 01:23 PM
20023
20028
20033

Related issues

Related to FreeNAS - Bug #34092: Fix middleware bug in rsync task quick schedulerDone
Is duplicate of FreeNAS - Feature #37503: Convert Cloud Sync Tasks to entity-formDone

History

#1 Avatar?id=55038&size=24x24 Updated by Zackary Welch about 1 year ago

  • Related to Bug #34092: Fix middleware bug in rsync task quick scheduler added

#2 Updated by Dru Lavigne about 1 year ago

  • Category changed from Middleware to GUI (new)
  • Assignee changed from Release Council to Lola Yang
  • Target version changed from Backlog to 11.2-BETA2

#3 Updated by Lola Yang about 1 year ago

  • Status changed from Unscreened to In Progress

#4 Updated by Dru Lavigne about 1 year ago

New cron job scheduler already merged to master. A new PR was opened for ticket #37503 that will fixed this issue.

#5 Updated by Dru Lavigne about 1 year ago

  • Is duplicate of Feature #37503: Convert Cloud Sync Tasks to entity-form added

#6 Updated by Dru Lavigne about 1 year ago

  • Status changed from In Progress to Closed
  • Target version changed from 11.2-BETA2 to N/A
  • Reason for Closing set to Duplicate Issue

Also available in: Atom PDF